Gigaset GS290, how to lock bootloader again?

Hello all,
I just got a new Gigaset GS290 and installed /e/OS on it. The device was shipped with Android 9 on it, so I updated to Android 10 first. After reaching version 10, I’ve done everything as described here: https://doc.e.foundation/devices/GS290/install

Everything runs good so far. But now I got this annoying message at system start:

Orange state.
Your device has been unlocked and can’t be trusted
Your device will boot in 5 seconds

Is there any way to get rid of this message, maybe to lock the bootloader again? Is there any command (like fastboot flashing unlock) to lock the phone?

Thank you for helping me out!

Hi @omovatet, ‘Verified Boot’ with ‘Locked Bootloader’ would be ideal, but does it really work?

Lock bootloader
Boot into fastboot mode.
Connect to USB and type fastboot devices to verify that it worked.

fastboot flashing lock to lock the bootloader.
Then confirm that the “unlocked” warning are gone.

At worst, the attempt ends in a bootloop. Then simply unlock the bootloader again.

Please try it and share your experience with us.

Hello SuzieQ

Thank you for your fast reply! I tried, what you wrote:

Now, this is the message I get:

Your device has failed verification and may not work properly.
Please download .... image with the correct signature or disable verified boot.
Your device will reboot in 5 seconds

It keeps rebooting all the time and I dont know, how to unlock bootloader again?

Edit: I managed to boot into fastboot mode by pressing volume up and the power button.
Then I just unlocked the bootloader again, as you told me and now the phone is booting again.
The orange state message still appears. Any other possible solution?

Thanks in advance!

Edit 2: Phone lost all its data. No problem, because I had nothing on it. So I had to go through the setup process again; choose language, timezone etc…

1 Like

Hello @omovatet ,
thanks for having the courage to try it out. It would have been too good if the ‘Lock Bootloader’ had worked. Now we have it and don’t have to speculate if and what works.

Locking the bootloader is a condition for a ‘Verified Boot’. Unfortunately, there are only about a dozen Android smartphones on which the re-lock bootloader is possible.

Unlocking the bootloader results in the deletion of personal data and device settings: this is what the inventor wanted, because it serves as a security feature aka protection mechanism in case the phone falls into the wrong hands.

Well, a degoogled AOSP Android 10 /e/ OS ‘Q’ for the GS290 is almost without alternative - “alternativlos” in German, isn’t it.

1 Like

The user must get used to this message. It remains as long as the GS290 works with a customROM.
Just think of it as a grudging “Thank You” from the device manufacturer in cooperation with its partner Google for the operating system change :))

That makes sense. Thanks for sharing that knowledge with me.

OK, that is fine. I was just curious, if the pre-installed version of the GS290, that comes with /e/OS has that same message showing up on every boot.

I do have the same issue currently that I stuck in this stage:

Orange state.
Your device has been unlocked and can’t be trusted
Your device will boot in 5 seconds

I can get back to the fastboot, but I actually don’t know how to solve it from this point of view. I tried to do the same steps of the installation again but to get it done, but it didn’t work again. Probably not a big surprise… the only command which didn’t get through easily was the “fastboot -w”. I got this information:

wiping userdata…
Invalid logical-block-size 512: must be a power of 2 and at least 4096.
mke2fs 1.44.1 (24-Mar-2018)
/tmp/TemporaryFile-C3B7tu: Nicht implementierte Ext2-Bibliotheksfunktion beim Erstellen des Superblocks
/usr/lib/android-sdk/platform-tools/mke2fs failed with status 1
mke2fs failed: 1
error: Cannot generate image for userdata

Does anybody know how to proceed or do I have to get back to the original ROM?

Looks like an incompatible version of the fastboot command.
Please use the fastboot command from current Android SDK Platform Tools to try again.

There’s perhaps even more to try: https://community.e.foundation/search?q=“Cannot%20generate%20image%20for%20userdata”

Thank you to @omovatet for the try to re-lock the bootloader and @SuzieQ for the explanation. I was also a bit confused about this message on my GS290. Besides this short confusion, /e/ works excelent with the GS290 so far.

Thank you @AnotherElk for the hint.

I flashed back to Android and tried it again, this time I used “./” in front of every command like “./fastboot flashing unlock” and it finally works properly.

1 Like

hello,

i tried to install e OS on my new gs290 as well.
I also have the problem …

wiping userdata…
> Invalid logical-block-size 512: must be a power of 2 and at least 4096.
> mke2fs 1.44.1 (24-Mar-2018)
> /tmp/TemporaryFile-C3B7tu: Nicht implementierte Ext2-Bibliotheksfunktion beim Erstellen des Superblocks
> /usr/lib/android-sdk/platform-tools/mke2fs failed with status 1
> mke2fs failed: 1
> error: Cannot generate image for userdata

i tried to install von ubuntu 18.04 on PC.

@AnotherElk what do you mean with " fastboot command from current Android SDK Platform Tools" ?
is there a specific command, different from the commands in the documentation?

i hope you can help me.
thanks alot.

There were fastboot commands with some incompatibility distributed via the package managers in certain Linux distributions for a while, so if you simply had the fastboot command preinstalled or installed it via the package manager of your Linux distribution, there was a chance you would end up with the error you experience. I thought this shouldn’t happen anymore, but of course this is dependent on how recent the fastboot command is in your Linux.

The certain way to prevent this from happening is to use the fastboot command from the current Android SDK Platform Tools.

The install guide for the GS290 says accordingly:

"1. Check fastboot version

fastboot --version

fastboot version 30.0.5-6877874

Caution: Versions provided by Ubuntu or some operating system are not up to date, do not try to flash your Gigaset with it. Instead, follow the instructions given here"

1 Like

i did as said in the documentation and downloaded the platform tools for linux (https://doc.e.foundation/pages/install-adb)

(base) gerkna@GDKPC: fastboot --version
fastboot version 1:8.1.0+r23-5~18.04
Installed as /usr/lib/android-sdk/platform-tools/fastboot

And did you do the other steps in the documentation as well to make sure you really use the downloaded command?

This version output strikingly contains your Ubuntu version number.
Anyway, I just quickly downloaded the platform-tools for Linux into an Ubuntu 18.04 via WSL and …

./fastboot --version
fastboot version 31.0.0-7110759

The preinstalled fastboot of my WSL-Ubuntu gives …

fastboot --version
fastboot version 1:7.0.0+r33-2

So, the fastboot command you are using still seems to be your Ubuntu’s fastboot command, which seems defunct for the purpose.

Please stick to the documentation closely.

If that is the full path to the fastboot executable, the command below should give the right version

(base) gerkna@GDKPC: /usr/lib/android-sdk/platform-tools/fastboot --version

thanks for your replys

i put android back on the device and tried again from the beginning…

i did the platform-tools incorrect.
now i get the correct version

gdk@GDK-PUC:~/platform-tools$ /home/gdk/platform-tools/adb
Android Debug Bridge version 1.0.41
Version 31.0.0-7110759
Installed as /home/gdk/platform-tools/adb
gdk@GDK-PUC:/home$ /home/gdk/platform-tools/fastboot --version
fastboot version 31.0.0-7110759
Installed as /home/gdk/platform-tools/fastboot

the part “add path to you pc configuration” didnt worked, i couldnt copy the folder to /home, so i typed the absolut path everytime deleted the line from .bshrc file

after unlocking, now i get the error:

gdk@GDK-PUC:/home$ /home/gdk/platform-tools/fastboot devices
GS290CTM401553 fastboot

gdk@GDK-PUC:/home$ /home/gdk/platform-tools/fastboot flash --disable-verity --disable-verification boot boot.img
fastboot: error: cannot load ‘boot.img’: No such file or directory

the downloaded images (boot.img, system.img and recovery-e-0.14-q-2021012698290-dev-GS290.img) are in the folger “platform-tools”

You need to specify the full path to the boot.img.

Yeah, that part of the documentation is wrong at the moment.

I’ve created an issue to fix the export commands one should add to ~/.bashrc

In that case it would be easiest to do it like this

gdk@GDK-PUC:/home$ cd /home/gdk/platform-tools
gdk@GDK-PUC:/home/gdk/platform-tools$ ./fastboot flash --disable-verity --disable-verification boot boot.img

Thanks for pointing this out @Ingo_FP_Angel. Will have the error corrected.

1 Like