Gigaset GS290 - Installation - Problem

Hi, I run into a problem when trying to install /e/ on my GS 290 (via Ubuntu 20.04)

I followed the documentation (and things went well until the first command of the installation: fastboot flash --disable-verity --disable-verification boot boot.img

Here I get the error message: “fastboot: error: cannot load ‘boot.img’: No such file or directory”

I have placed all 3 installation files (system.img, boot.img, recovery-e-0.14-q-2021012698290-dev-GS290.img) in the same folder as adb and fastboot (/home/mitch/platform-tools).

What am I doing wrong? Thanks in advance, for any help.

Is adb already installed on your system?

To test, in that working folder run

./fastboot --version


fastboot --version

Does that give the clue? :slightly_smiling_face:

Thanks for helping me!

Yes, I followed the whole preparatory procedure from the scratch

By working folder you mean the folder where the boot.img file and adb, bootloader etc. are contained in my case, right?). The reply is in both cases ( with ./ and without) the same:

fastboot version 31.0.2-7242960
Installed as /home/mitch/platform-tools/fastboot

If I type “adb --version” it states:
Android Debug Bridge version 1.0.41
Version 31.0.2-7242960
Installed as /home/mitch/platform-tools/adb

Also the phone seems to be in fastboot mode (that is what it states on the phone) and is recognised by the computer: If I type “fastboot devices”, it states
GS290CTM701899 fastboot

I also checked the hash256sums to make sure that the files are not corrupted.
I enabled USB debugging and unlocked the device (step 3 of “Before install”) with
adb reboot bootloader
fastboot flashing unlock
(which I confirmed on my phone screen confirm by pressing volume up)
This all seems to have run pretty well.

This tread is marked solved using Platform Tools 30.0.5 on a Gigaset GS290.

1 Like

OK, thanks. I will try this.

One technical question, I am a bit worried my phone might run out of battery if I leave it the whole time connected with the laptop on fastboot.

Can I simply disconnect the cable to the laptop and press the PowerButton for 15 sec to shut the phone down (and restart tomorrow) or what would you recommend me?

I certainly would hope it would shut down and restart ok in the morning. :slight_smile:

You are correct it will not charge on Fastboot.

An alternative is to see if the phone charges while in recovery mode. However, I think you must power off the phone to reach recovery.

Reading all that you say you have done with this phone, I would guess you have not interfered with the original system? If that is the case the power down should be problem free.

Puh! Yes, fortunately I can still boot the system normally and in Recovery. :sweat_smile: So shutting down, rebooting and loading is not an issue - for the time being (I get the “orange state” message at the beginning that you cannot trust the device anymore cause it has been unlocked, but I guess that is normal).

I tried to find the 30.0.5. version from the Android site, but I fear they only offer the latest version. I also did not find a site where to download older versions. Do you have an idea where I could get it from ? (I suppose it also has to be a reliable source).

I have another question with regard to the command “fastboot flash recovery recovery.img”. Is this the correct command? The file I downloaded is entitled “recovery-e-0.14-q-2021012698290-dev-GS290.img”. Do I have to change the name of the file into recovery.img before executing the command or will it work anyway?

(Sorry for all these questions. All this flashing stuff is pretty new to me. I am reading (and learning) a lot at the moment, but it seems that for one question I solve, there are two more popping-up :roll_eyes:) But I really like the /e/ project and want to be able to flash my friends’ phones)

Hi @mailanmitch, I recently had trouble using latest platform tools on ubuntu 20.10 which were resolved by removing the outdated versions of adb and fastboot that come pre-installed with ubuntu. Could this have a bearing on your problem?

Excuse me for answering this question not addressed to me. You can change the name of the downloaded recovery image file to match the name in your command or you can change the command to match your file.So without renaming your file the command would be:

fastboot flash recovery recovery-e-0.14-q-2021012698290-dev-GS290.img

Personally I prefer to keep the long recovery names to help identify files on the pc as they accumulate!


I certainly agree with both those points, thanks, @chrisrg.

Of course I did not follow up in my first approach to your problem, but assumed from your response, there was not a conflicting version!

I had a link to “developer” platform-tools by version, but it is not found (may be due to Google signing in issues that I cannot do).

This appears to be a functioning link to platform-tools version r30.0.5-linux, should you choose to try it!

To look for other versions, you must accurately change the url with due regard to SDK Platform Tools release notes

1 Like

Thanks a lot to both of you @chrisrg and @aibd!

I already had read in the /e/ install documentation that “Versions provided by Ubuntu or some operating system are not up to date, do not try to flash your Gigaset with it.” Therefore I manually installed the latest version.

When I type the command “fastboot --version” it states “fastboot version 31.0.2-7242960”. Therefore I thought this is the version which is used. So there nevertheless might be a problem with a conflicting older version existing somewhere else on the computer?

So if I understood correctly (and combining your two suggestions) your advice would be:

  1. First remove the outdated adb and fastboot versions. Then try again the same procedure. How did you remove the older versions? (I couldn’t find the pre-installed versions)

  2. If it still not working, additionally install version 30.05 (given the success of other users with this version) and try again.

Do I get it right?

P.S. Not sure this is of importance, but I also followed the advice from the /e/ documentation “Add the path to you PC configuration” ( ) and typed the below command to my bashrc “export PATH=”$HOME/platform-tools:$PATH"

Should I better delete this line or is it good to have?

You can issue cmd: “echo $PATH” to check if it is set up ok. Here’s the output I have:

Also cmd: “which fastboot” should tell you what location of fastboot would be used

Also check the bin folders to see if other fastboot and adb still there
I found them in /usr/bin/fastboot and /usr/bin/adb
You can remove them with “sudo rm /usr/bin/fastboot” and “sudo rm /usr/bin/adb”

I’m not 100% sure, but this message to me does not sound like different versions of fastboot interfering on the computer but simply that “something is wrong” with file names and/or current working directory.

You wrote that you added “export PATH=”$HOME/platform-tools:$PATH" to your bashrc.

That leads me to my guess: you did not change into the platform-tools directory before executing the commands, right?

Does it work when you do

cd /home/mitch/platform-tools
fastboot flash --disable-verity --disable-verification boot boot.img

or optionally

fastboot flash --disable-verity --disable-verification boot /home/mitch/platform-tools/boot.img
1 Like

Thanks @Ingo_FP_Angel, that is the fundamental of the error message. As, @mailanmitch, you asked me this question early on, I think it is important to understand the concept of working folder, and be 100% consistent.

Thanks @Ingo_FP_Angel. My guess would be, yes I did that. But I better check again.

I fear , I won’t find the time for this today and I prefer to do this without hectic (I also think I better read and and understand a bit more about working folders / working directories). I’ll be back with news on Wed!

… and perhaps find a tutorial on adb, perhaps the commands push and pull, to get a little real life experience with adb. :slightly_smiling_face:

When I am in this directory /home/mitch/platform-tools and enter the command (fastboot flash --disable-verity --disable-verification boot boot.img), I get indeed a different error message:

“: terminating with uncaught exception of type std::out_of_range: basic_string
Abgebrochen” (sorry my language settings are DE; abgebrochen = terminated/ canceled)

Any ideas what this could mean?

PS: This is the result of echo $PATH:

“which fastboot” gives the following result: /home/mitch/platform-tools/fastboot
I can confirm that fastboot and adb are also contained in “/usr/bin/fastboot” and “/usr/bin/adb”

No. Although I’ve seen it before somewhere. The other two are more likely to know about that one.

I’ve looked at the install instructions that I assume you are following and it all looks straightforward fastboot flashing. There is something fairly basic hampering you at the moment I think.

My instincts are to make sure fastboot and adb is all correct first, even though this might not be actually the problem. You have put the platform-tools folder in path I see, so that means you should be able to issue commands for those from any location. You could test a fastboot devices command with terminal opened in another folder. Did you check /usr/local/bin and those other locations to see if the pre-existing adb and fastboot are still there?

Ah ok, well those are the one’s to remove

You can remove them with “sudo rm /usr/bin/fastboot” and “sudo rm /usr/bin/adb”

1 Like

@mailanmitch, @aibd, I’ve been trying to source older platform tools, esp the 30.0.5 version. Can’t see anything yet, although from the other post it looks like the complete SDK can get them? I’ve not used that before and don’t know if it works on linux…

I removed /usr/bin/fastboot and /usr/bin/adb - however the error message is the same. Or would I have to restart the laptop?

@chrisrg I am not sure I understand what you mean with your last post (given my rather limited knowledge I guess :wink:

I got a link from @aibd where to download version 30.0.5 which I did. I extracted them into a new folder “/home/mitch/platform-tools2” (and of course moved a copy of the 3 .img files into it). When I am in this folder and type “fastboot which version” it still shows the older folder (/home/mitch/platform-tools).

What would you suggest me to do? Shall I delete the old platform tools folder and after that rename the new one into “/home/mitch/platform-tools”? Or can I keep both version and make him adress the right fastboot version?