Gmail account authentication error since update to 1.2

Afrer updating /e/OS to 1.2 on FP3 I was greeted with an error notification from the Mail app about needing to fix authentication settings.

After clicking on that, I was taken to the account settings of the Mail app and when clicking Next there, accounts.google.com opened in the browser and I was greeted with:

Error 400: redirect_uri_mismatch

How do I fix this?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

2 Likes

I am having the exact same problem as described by @hook only on a Samsung S9+.

@Brad @hook The update of mail app introduces several changes about the authentication. Can you try to delete your Gmail account from Mail app and recreate it? Let me know if it fix the issue.

4 Likes

That worked. Gmail seems to be working in the email app once again. Thank you.

1 Like

That worked for me as well, thanks @nicofonk

1 Like

worked for me too, thank you!

1 Like

Did anyone manage to add a gmail account into the mail app without adding your google account to the system accounts ?
Which auth method do you choose in the list ? Oauth 2.0 keeps sending me to the redirect_uri_mismatch page even after deleting the account and trying to add it again…

I’m pretty sure that my google account did not appear in the system accounts and that only the mail app had an access to my gmail account (or is my memory failing me ?).

1 Like

I don’t use the Mail app (I use FairEmail instead), but need the Google account to access my work calendars through Oauth 2.0.

What I did was to add it through the System Accounts and now the calendars work (GMail in Mail app did as well, but I later intentionally removed mail sync) again.

I did take a look at the MicroG settings and it does not list the account there, so my guess is that it’s fine to add it through the System Accounts without fear of having Google suddenly have snooping access. (It’s nothing more than a guess though.)

Ok, thanks for your answer.

Maybe @nicofonk can confirm / give more information ?

When adding an account in the Mail app, after entering the email address it asks me to choose what type of account it is. I see that there is Google but also Google microG. Anyone knows exactly what’s the difference ?

I can otherwise choose to configure the account manually but when I do this I always land on the redirect_uri_mismatch page.

I will probably just stop adding my gmail account in the mail app since I am progressively moving the use of my gmail address to the e.email one. But this could be useful to others.

2 Likes

I have the same problem. I only want GMail to check for my E-Mails and for nothing else.

@raphm you are right, it used to be this way but now after the recreation/reconnect of the GMail-Account it fully sinced my phone to the Google Servers without a warning. It freaking sinced everything!
Now Google got my full adressbook what is something I always wanted to prevent from happening and also a reason I went to /e/OS.
This is ridiculous. e/OS/ is slowly moving towards a bad route…

@Thunfischsalat /e/OS system mail app is based on K9 mail if I’m not wrong. So I suppose this is a new (?) behaviour of K9 mail. Maybe /e/OS could have anticipated better here to warn about this default behaviour of the app when adding a gmail address to the app. But I’m quite sure /e/OS is not “slowly moving towards a bad route”.

It’s probably technically possible to only add your gmail account, probably using microG (search for it in the forum). But I can’t help you with that, sorry.

Neither K-9 Mail, nor /e/'s Mail fork will be sending any information to Google apart from login credentials. They will certainly not be synching your address book or calendar.

From reading this thread it seems that people are adding their Google / Gmail account to the phone using Account Manager. When they do this, what happens with sync will depend on what options they have set up in their Google account. I have sync - and pretty much everything else - turned off in my Google account and I am pretty sure nothing is synched between my phone and Google.

@petefoth yes you are right this is probably what’s happening, but the tricky thing is that it is the mail app that opens the account manager when you add a mail account into the app. And I don’t think it’s easy for everyone to realize it, so it can lead to misunderstandings.

1 Like

Does anyone know of a way to use microG with the mail app rather than adding the Google account in Account Manager? I haven’t been able to find anything

As other of you I would like to avoid any Google account at system level as I’ve found no information about what effectively happens when you setup a “Google” or a “microG” account in the account manager.
I understand the proposed workaround is related to such accounts.
So is there any other workaround to get rid of the “Error 400: redirect_uri_mismatch” when activating oAuth2 from Mail ?