Gmail account authentication error since update to 1.2

Afrer updating /e/OS to 1.2 on FP3 I was greeted with an error notification from the Mail app about needing to fix authentication settings.

After clicking on that, I was taken to the account settings of the Mail app and when clicking Next there, accounts.google.com opened in the browser and I was greeted with:

Error 400: redirect_uri_mismatch

How do I fix this?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

I am having the exact same problem as described by @hook only on a Samsung S9+.

@Brad @hook The update of mail app introduces several changes about the authentication. Can you try to delete your Gmail account from Mail app and recreate it? Let me know if it fix the issue.

3 Likes

That worked. Gmail seems to be working in the email app once again. Thank you.

That worked for me as well, thanks @nicofonk

worked for me too, thank you!

Did anyone manage to add a gmail account into the mail app without adding your google account to the system accounts ?
Which auth method do you choose in the list ? Oauth 2.0 keeps sending me to the redirect_uri_mismatch page even after deleting the account and trying to add it again…

I’m pretty sure that my google account did not appear in the system accounts and that only the mail app had an access to my gmail account (or is my memory failing me ?).

I don’t use the Mail app (I use FairEmail instead), but need the Google account to access my work calendars through Oauth 2.0.

What I did was to add it through the System Accounts and now the calendars work (GMail in Mail app did as well, but I later intentionally removed mail sync) again.

I did take a look at the MicroG settings and it does not list the account there, so my guess is that it’s fine to add it through the System Accounts without fear of having Google suddenly have snooping access. (It’s nothing more than a guess though.)

Ok, thanks for your answer.

Maybe @nicofonk can confirm / give more information ?

When adding an account in the Mail app, after entering the email address it asks me to choose what type of account it is. I see that there is Google but also Google microG. Anyone knows exactly what’s the difference ?

I can otherwise choose to configure the account manually but when I do this I always land on the redirect_uri_mismatch page.

I will probably just stop adding my gmail account in the mail app since I am progressively moving the use of my gmail address to the e.email one. But this could be useful to others.