Gnss not working on moto E

I just reinstalled the latest official build on my moto E. Everything work excepted the gps. Maps, osmAnd, GPSTest apps can’t access gps.

I checked :

  • the autocheck in microG setting : everything is ok;
  • the location modules : Mozilla and Nominatim are both turned on;
  • The three apps are allowed to access to location;
  • The location turned on. No airplane mode, etc;
  • I tried with fakeGPS instead of real position. No result.

Everything worked before reinstallation. So it is clearly a software problem.

Try to revert back to previous build…

The previous one was an unofficial build, without update. That’s the reason why I changed.

What is your /e/ version and device codename ?

It is Surnia.

[useless text to reach 20 characters]

I found that surnias don’t get a gps signal at first but will do outside after 10 mins or so. I use mine as a sat nav.

I will test, but it doesn’t give me so much hope. It doesn’t seems to be linked with gps signal, as it should also find a position with ground antenna only. And it should display a fake position when fakeGPS app is enabled. So, it is more like if the location functionality was never enabled or something like that.

UPDTATE : I tried to reboot the phone and to activate the GNSS outside, and after some seconds, it worked. I tried to disable wifi and to activate fakeGPS and it stopped to work. I rebooted and activate only GNSS, without wifi and it worked. I launched fakeGPS, and it stopped.
I rebooted indoor and reactivated wifi positioning and it found a position at 150Km from me.
So it seems the positioning by satellites work. At least until I try to cheat it.

So, if you encounter problems with latest e-0.20-q,
try e-0.19-q