Googel Pixel 1(st gen) with And. 10 stock rom -> ready for e-0.13-p-20201208?

Dear all,
not sure if I got this right. I’d like to change a Pixel 1st gen from Android 10 stock rom to /e/, current release (e-0.13-p-20201208), which is Pie and not Q. Will it break the device or cause major problems?
In other words, do I have to downgrade to V9 stock rom or wait for the /e/-Q-release to appear? Just asking since I remember difficulties to do the stock downgrade with a previous Pixel. Did not accept the lower version stock rom and I had to give up.

Thanks for your hints

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi @uzeka,
I haven’t held a first-generation Pixel 1 in my hands yet, but from Pixel 2 onwards, I’ve held all the others available. I have downgraded the ‘Factory Images’ Stock Android from 11 to 10, to 9 and even to stock Android 8 and later upgraded it again. It has always worked perfectly. Google’s Pixel phones are very robust.

If you follow these flashing instructions via fastboot commands, making the base firmware is well manageable. So you don’t have to wait, install /e/ OS e-0.13-p- (9-Pie) on your Pixel 1 ‘sailfish’ now.

Hi @SuzieQ,
thanks a lot for your quick reply, much appreciated. The reason for my late answer is this Pixel refusing to accept the job.
Connetced it (Android 10) to USB. Adb and fastboot ready to go and ‘seeing’ the phone.
Installed the vanilla rom 9.0.0 (PQ2A.190205.003, Feb 2019) as advised.
Reboot: Fine.
Flashed latest twrp-3.5.0_9-0-sailfish following the recipe - ok, looks good.
Sideloaded /e/ (e-0.13-p-2020120889008-dev-sailfish) following the recipe: abort at 34% (says terminal), device flashing going on forever, finally aborting. Phone remains in a state where it reboots to twrp only.

Restarted the same sideload command after phone reboot into twrp:
Flashing proces on the phone seems to restart at the step it stopped before, at the same time nothing is transferred from PC to phone (adb sideload command aborts quickly).
Assumption: There must be file residues from the first sideload attempt on the phone forcing the aborted flashing to restart over and over. (Wrong idea?)
Tried every wipe method with twrp to get rid of the assumed residues, but no change.
Finally wiped everything, so only twrp remained, at last only the bootloader remained.

Well - same procedure from the start.
Booted to bootloader (only option left),
checked fastboot - fine, seeing the phone,
flashed vanilla stock rom with ‘flash-all’ script, this time a slightly newer 9.0.0 (PQ3A.190801.002, Aug 2019),
-> terminal says, all fine (success),
-> reboot: Google logo appearing, then black screen, buttons not working.

This is called a bricked device, right? Seems to be a zombie, though, the case remains warm, so it’s still busy with something.
This is my fourth Pixel 1, three went smooth to /e/ 9 (from Android 9) an I expected an easy walk this time as well. :see_no_evil:

Could there be any chance to get the phone on the hook again?


PS: No, I’m not installing Pixels for commercial reasons. One dropped and is hardware damaged (repair shop gave up), second is in use but battery is nearly dead, third is in use but mic failed and needs replacement, going to repair.


The flash-all thing didnt worked for me before, so this time I not even tryed.
I was with Lineage (android 10).

I downloaded the stock firmware (android 9) zip file from google and unzip it. There was one more zipped package in the unziped folder, so I unziped it too.

# adb reboot fastboot
# fastboot flash boot <boot image file name>.img
# fastboot flash bootloader <bootloader image file name>.img
# fastboot reboot-bootloader
# fastboot flash radio <radio image file name>.img
# fastboot flash system <system file name>.img
# fastboot flash vendor <vendor file name>.img
# fastboot reboot

As it is said in this site.

Stock booted well. Developer Options. adb. Then (recovery.img):
# adb reboot fastboot
# fastboot --skip-reboot flash boot twrp-3.5.2_9-0-sailfish.img
# fastboot reboot recovery
In recovery (
# adb sideload recovery
In recovey: reboot into recovery
Do the wipes/format.
And adb sideload /e/.

ps: is a bit out of chronological order