Google - Pixel 4a 5G - bramble - Documentation Suggestions

A german user also had issues with the easy installer, as documented I suggested him to use the flash tool from google to install Android 11 and after that the installation with eay installer was a success.


Have you upgraded the vendor part the stock firmware fisrt, when attempted to switch from “r” to “s” ?

What are the steps to upgrade to “s” (Android 12) - currently, or any other future update?

Seems that it can be a bit different than currently described in the documentation (sorry can’t post more than two links as new user).

I tried to write down how it possibly can be done. :warning: I’m a newbie here!! I did not test it on my device (glad it’s running now with Android 11 after some troubles - downgrading required…). Maybe some experienced can correct the below… maybe it’s still not possible to use the System Update on the device… at least it’s offered :warning:

Upgrade you /e/OS to a higher Android release using System Update on the device

1 Update custom device firmware


You will find these files useful if you have experienced a failure to take an OTA. This has the same effect as flashing the corresponding factory image, but without the need to wipe the device or unlock the bootloader.

How to find out what version to take for /e/OS 1.6 (Android 12)?

Currently these are available from the site above for Android 12:

12.0.0 (SP1A.210812.015, Oct 2021)
12.0.0 (SP1A.210812.016.A1, Oct 2021, Verizon)
12.0.0 (SP1A.211105.002.A1, Nov 2021, Verizon, Verizon MVNOs)
12.0.0 (SP1A.211105.003, Nov 2021)
12.0.0 (SP1A.211105.004, Nov 2021, Telstra, Optus, Vodafone AU)
12.0.0 (SQ1A.211205.008, Dec 2021)
12.0.0 (SQ1A.220105.002, Jan 2022)
12.0.0 (SQ1A.220205.002, Feb 2022)
12.1.0 (SP2A.220305.012, Mar 2022)
12.1.0 (SP2A.220405.003, Apr 2022)
12.1.0 (SP2A.220505.002, May 2022)
12.1.0 (SQ3A.220605.009.A1, Jun 2022)
12.1.0 (SQ3A.220705.003.A1, Jul 2022)

Take the latest one 12.1.0 (SQ3A.220705.003.A1, Jul 2022)?
Take the latest major release version that is older than the Android version to upgrade to (see next step)?

2 Upgrade Android

Starting the /e/OS update using the System settings > System Update on the device.

E.g. upgrading from /e/OS 1.5 to /e/OS 1.6 (Android 12) from Dec. 13th 2022 (as shown on the device System Update).

1 Like

Yes I confirm, the installer doesn’t work with Android 12, it’s Ok with Android 11

Does anyone know if the easy-installer works with Android 13 ?

Of course not, /e/ T builds will not be released until six months

Recovery fails to install… “error boot prepare.”

Update: recovery still fails despite downgrading to Android S version 12. I am now following another guide on here to downgrade completely to “R.”

Installed /e/ on many devices. Today encountered an odd one:

I followed the instructions and flashed the latest factory image from 5-2023 Android 13. Trying to boot to recovery encountered, “error boot prepare”

I submitted a Gitlab issue:

Same for me. Didn’t notice the Android 12 requirement at first, so it understandably didn’t work. Tried all versions of 12 available using the official android flash device. With every one of them the same error after flashing and trying to boot into recovery, “error boot prepare.”

Even went back, installed Android 11, tried the android 11 recovery. Same issue.

Anybody able to help with this? Been no update to the GitHub report in the past month.

Error boot prepare suggests that not every trace of the higher Android version / previous system was removed.

A web search will produce some suggestions.

Just to check low hanging fruit, when you used androidflashtool did that process ensure that you did full format data and removal of all accounts from the device ?

There are 4 market variants of this “gogol pixel 4a 5g” :

(g025e) USA, Canada,
(g025i) international,
(g025h) Japan,
(g6qu3) USA’s verizon carrier

according to Only differences seems to be used band.

There is no mention of model restrictions in and “other models are not supported” in our page seems leads to misinterpretation :

Trying to install “bramble”, I’m stuck at this stage : Flashing additional partitions.
The install guide says : “Unzip the /e/OS Recovery file”.
But the recovery file is an IMG file, not a zip file. Therefore, it can’t be “unzipped”. Can I just skip this part and move on to the next one (flashing a recovery image) ?
Thanks for your help.

It is a current issue mentioned

Thanks a lot for the workaround and the neat instructions on the linked page.
payload-dumper-go did the job. I now have all I need to proceed with the install.

I’ve just installed /e/ on my Google Pixel 4a 5G (bramble with Android 13) and I’ve come across the same problem : after flashing the recovery file provided on the download page, I ended up with not being able to boot into recovery at all (same message as above : “error boot prepare”).
What I did was : using “payload-dumper-go”, I extracted vendor_boot from the sytem zip file and flashed it in replacement of the provided recovery (e-1.16-t-20231018…img)
I could then boot into recovery and proceed with the installation (format the device and install /e/OS). Hope that helps.

1 Like

Today I installed /e/OS 1.16-t on my Google Pixel 4a 5G, coming from LineageOS 19.1 (@jarival your hint regarding vendor_boot was a great help, thanks for that!).
After installation I wanted to re-lock the bootloader with command flashboot flashing lock (using fastboot 34.0.4), but after that I received a message that no valid OS was available (and consequently the device could not be started).
Is it generally impossible to re-lock the bootloader (then this should be mentioned in the documentation) or did I do something wrong?

I also meant to re-lock the bootloader after installing /e/, but after consulting various websites, I decided not to. This site mentions that : “Relocking the bootloader can not be undone on many devices”. Furthermore it appears that if you relock the bootloader, you will have no other choice than go back to stock ROM. I would be delighted to learn that this is not true, but in the meantime, I will keep my bootloader unlocked, in spite of the annoying message reminding you that your bootloader is unlocked every time you switch on your phone !

With eOS only a few devices can be locked. In the installation document, it is not mentiond for bramble. Thereforejit is not possible

1 Like

Thanks for clarifying, this complies with my experience.

To be precise, the documentation regarding “Bootloader relocking support” says “Data unavailable”, which imo means that it is unknown or not yet clarified.
If it’s clear that relocking is not possible, the better solution would be to clearly state “Not supported”.

@jarival For Pixel 4a 5G, re-unlocking is possible. I did that after I recognized that locking the bootloader prevented the device from booting. However, unlocking again reset the OS to initial status, so all data was lost (which was no problem in this case) and I had to re-run the setup steps.

Apparently, the relocking status is known, since the device is mentioned in the section “Bootloader can NOT be relocked” on this page. In my opinion, that should be made clear in the install guide.

1 Like

Although model G025I is not mentioned in the supported devices list, I can confirm that /e/OS runs flawlessly on that device. :+1:

1 Like