Got through installer, but

Hi,
Well I got through the installer but the very last screen where it said I would see the e logo / animation, my phone started just flashing the Galaxy s9+ logo -on for 8 seconds off for 2- over and over again… it just does that and nothing more.

I am wondering what could have gone wrong? Does this sound familiar to anyone and does anyone have any suggestions for me or something I could try ?

update: I can add that holding on and Bixby and Volume UP gets me into TeamWin Recovery Project version 3.2.3-0 … I do not know what to do from here however :frowning:

update 2: I was able to get the Easy Java installer to see my device after I booted into TeamWin and am trying to go through the Easy Installer screens again…

update 3: OK got stuck at unlock OEM screen because, I suppose, it’s waiting for a signal from Android but since I am in TeamWin and can’t get to anywhere else I am not going to pass this OEM unlock screen (despite the fact that the OEM Unlock has been successfully unlocked during my earilier attempt).

So that’s where I am now.

OK Unless I can get out of this I am pretty sure the phone is bricked. I am only in 1 of 2 states:

Either I press Bixby + Up Volume and On in which case I can only get to a screen which says Downloading: Do Not Turn Off Target

Or I try off the phone and boot normally in which case the Samsung infinite loop appears as described above.

Both appear to be dead ends. I cannot get my computer to see the phone at all.

Any suggestions welcomed!

Upate 4(!) I see I am able to boot to the full TWRP menu, (power + Bixby + Volume Up starting from from phone off now shows me that) so this gives me hope I can recover fully.

Ahh… feel free to just throw anything out there you can think of, obviously I am quite lost !

Thank you !!!

Hello,

If you can reach the recovery mode and the download mode, your phone is definitely not bricked.

In case you need, you could use this HOWTO (TWRP is already installed so you can directly read the parts after this step) to do a manual installation.

But before this, I suggest you to enter into TWRP (the recovery mode) like you did, and go into Reboot > System.

If the e logo doesn’t shows up and you are still facing the bootloop, enter in TWRP again and go into Wipe > Format Data > type “yes” and enter > Reboot System > Do Not Install.

If it doesn’t work, then /e/OS isn’t installed correctly and you will have to download it and install it manually as stated in the HOWTO I shared above.

1 Like

Anonyme,

Your instructions are for Windows users and I am on Linux so I used the original instructions for this phone, located here:

I get to the very last item to do which is sideloading (I am assmuing you understand where this is and what I am talking about but if not let me know ! ) ; I have the following confusion and get the following error:

my confusion-
the instructions say type :

adb sideload filename.zip

but actually, I am not sure what filename.zip is in this context. It would be better if it were expressed as e-0.1. xxx star2lte.zip so I am certain that of all the files I downloaded, that is the one which is sought at this point in the process.

Assuming that it is the file whose name I am supposed to type in to the adb sideload command, it fails at this point.

I have two versions of the xxx star2lte.zip on my machine. Both have the exact same name down to the smallest detail and both were downloaded from /e/'s own site. I tried sideloading both of them in succession, so two different attempts. Both failed with the errror messages detailed for each below.

( I know they are different because the latest one’s md5 checksum- which I just downloaded a couple minutes ago, so 5PM EST on Oct. 23, does NOT match the posted checksum (!). The one I downloaded a few weeks ago does match the posted checksum.)

The non-matching file’s md5 checksum (as calculated, not as written next to the file on /e/'s site) begins with b48 and ends with 70f.

The matching file’s md5 checksum (as calculated, and also as written next to the file on /e/'s site) begins with 75c and ends with 5e4.

On my linux machine, using the non-matching checksum version of the file, the command line says:

adb server (41) doesn’t match this client (39); killing…
daemon started successfully
Total x-fer: 0.00x

On my linux machine, using the matching checksum version of the file, the command line just says:

Total x-fer: 0.00x

In both instances on the s9+ phone, the s9+ phone says:

Starting ADB sideload feature…
Installing zip file ‘/sideload/package.zip’
Unmounting System…
Warning: No file-contexts
detected filesystem ext4 for /dev/block/platform/11120000.ufs/by-name/VENDOR
mount: Failed to mount /dev/block/platform/11120000.ufs/by-name/VENDOR at /vendor: Invalid argument file_getprop: failed to stat “/vendor/build.prop”;
No such file or directory
Updater process ended with ERROR: 7

The source for both of the files- the matching and non-matching- was this webpage:

https://images.ecloud.global/dev/star2lte/

and the file both times was named:

e-0.11-o-2020082970470-dev-star2lte.zip

which is the first one on the top of the list of candidates.

Let me know if there’s anything else you need to know and I will do my best.

Much appreciation.

TWRP is already installed so I it doesn’t matter which operating system you have, instructions are the same now.

filename.zip is the zip file you downloaded (/e/OS).

If sideload doesn’t work just install /e/OS like in my HOWTO.

I get the error 7 business. When I try to edit the file as described by the “error 7 fix” by opening the archive, I get on Linux “an error occured while loading the archive . Command exited abnormally.”

That’s what happens.

When the error 7 occurs, there are a few solutions:

  • Downgrade from TWRP 3.4.0 to TWRP 3.3.1 (but you aren’t on this version).
  • Update from an old version of TWRP to TWRP 3.3.1 (by downloading the new .img file, going into TWRP > Install > selecting img instead of zip files > selecting the new .img file to install it).
  • Your device is not compatible with the zip file you want to install.
  • Look at this topic.

The error I get (see my immediately previous post for the error message ) implies that the xxxstarlte.zip file I downloaded is actually a Windows-specific application:

I am just assuming that because Postmarket is a Linux OS, that means the files I am downloading are also Linux files.

What if that’s not right? Am I working with the wrong files for the OS I am trying to install /e/ through? Are these xxxstar2lte.zip files I am obtaining for Windows machines and not Linux ? Is that why they are .zip and not .tar? Is that why everything is failing?

When I said that I meant not compatible with the OS you want to install.

zip isn’t Windows specific, I use this compression format on Ubuntu without any issue.

I don’t know why it doesn’t work I can’t help you more, just try again and again from scratch, redownload files, install TWRP 3.3.1, and hope.

I am on TWRP 3.2.3-0 so unless it doesn’t work but a downgrade to 3.3.1 does work this is not my problem. (does anyone use 3.2.2-0 successfully?)

  • Your device is not compatible with the zip file you want to install.
    lol… is this the same as saying “it doesn’t work” ? …lol…is there another.zip file somewhere?
  • Look at this topic

Exactly. I do have a reasonable suspicion that the getProps section is causing the trouble because of the error message including something about how it can’t find “vendor/build.prop”. However, when I attempt to open the xxxstarlte.zip file, I can’t; it fails. ( see my post in this thread starting with “I get the error 7 business”. ). I don’t have any issue with any other zip file so I don’t know why I do with that file.

Also, there’s the issue of the same named file having different md5 hashes which could somehow be related to a problem… like the files themselves on the /e/ server are corrupted for example.

I would gladly open the file and nuke the props section, but I cannot open the file on Linux Mint using the archive utility and I don’t know why.

My repsonses are getting a little out of order. I am just reading this now but it appears in the thread timeline I replied to it already.

Anyway yes, try and try again starting from scratrch and hope. That is truly the best advice and I will do just that. Thanks for your help !

Cheers!

OK I have to say that for whatever reason this phone is not compatible with the project despite being listed on the list of supported phones.

The thing with a project like this is because they’re not the original engineers of the phone or its software, they are really just best guessing what is needed to make /e/ work.

Even when it works, there’s just no way for anyone to know definitively why it worked except that nothing went wrong. So your sense of competence and control when it does work is an illusion. The bottom line is, as a dev, you can’t achieve mastery and make the type of guarantees a commercial product can make unless you control the platform.

I appreciate the time everyone took to try to get this going. I will try to load LineageOS and Gapps on it and failing that, it’s really sort of useless to anyone now. :frowning:

My suggestion would be to first go to the stock-rom version that you are trying to install (in this case Oreo I would assume). After installing this stock version, it would be good to re-try to flash this Oreo e-version.

OK this phone’s original OS was a non-English installation. I know the model and sub-model but when I look at the stock ROMs they’re by cnountry and or language. My question is- does it matter what stock ROM language I put on this phone or does it need to be the same language? I cannot tell you what language is was because I could not read the script. It was Vietnamese of Thai or something like that…a non-Roman alphabet system.