GPS experiences on FP3, Q and R

I recently tested both Q stable and R dev versions on my FP3. My experience was good, except that GPS and location features were very unstable for me. This is not a request for troubleshooting, as I’ve already removed e-os and reverted to stock (having usable GPS is kind of a need for me). I’m just wondering if anyone else have had GPS issues and if you were able to resolve them. If you were, I’d be willing to give e-os a new shot.

On Q, apps were able to accurately use GPS occasionally, but would then fail after some time. This happened to both e-os (Magicearth) and third-party apps. Both Osmand and Opentracks seemed completely unable to use location services. I tested this with default settings, and confirmed that all Microg settings related to location services were turned on. I also tried installing several UnifiedNlp modules from F-droid, such as Deja vu, but I still had the same issue. I tried all the fixes mentioned in this thread.

On R, none of the apps were able to detect my location. A shame, since I was impressed with Android 11’s features and performance.

I have an FP3 from Fairphone, so not a Murena device.

Again, wondering if anyone else have had similar issues. If not, might be just my device not playing well with UnifiedNlp or microg.

I have and had no problems whatsoever with location use by any App (mainly OsmAnd, but used other Apps from time to time, too) on p-dev and q-dev on my Fairphone 3.


I have also not had any issues getting gps location either.
In terms of not detecting the location, if gps has been swiched off for a while, then it can take around 1 to 2 mins (sometimes > 5 mins) to get a initial fix as it has to download new location data from the gps satellites. Although you may have already waited that long, so that might not be relevant.
If it’s regulary dropping out after connecting then I’m not sure what the issue could be.

Over a period of nearly a year I have made the same observations as @jeos, particularly with a new install.

I did never remember to test differently, but my first experience of it has always been with Magic Earth (Maps app).

The first thing I do is go outside (actually on a long walk or bike ride) with mobile data off and no possible network connection (other than GPS).

I guess I always turn on Maps at some point outdoors, and my location is usually correct. Same can happen if the phone has been powered off.

I am in the habit of installing OpenTracks very soon after install. I set it up to use offline mode (with a downloaded map). At one point I thought that OpenTracks somehow forced GPS to stop being lazy. I also felt somehow Maps preferred to just use “network location”, and not bother to wake up GPS - but that has to be speculation.

Sorry, subject is FF3, mine a Samsung A3.

Thank you for your replies! Good to know that GPS usually works just fine on an FP3. I might do another trial install of e-os either today or next week to perhaps properly figure this out.

I am now running R with a fully functioning GPS. My mistake, embarassingly, was to only test the GPS indoors. Once I went outdoors the connection picked up and seems to be very accurate. Again, thank you for your responses which made me attempt this again.


I’m running FP3+ with /e/OS e_FP3-user 11 RQ3A.211001.001
When i’ve got

  • GPS enabled,

and in settings wifi and bluetooth scanning:

  • wifi-scanning disabled and
  • bluetooth-scanning disabled

My “GPS status 11.0.307” (set to source “GPS only” ) says
“fix stat 0/23”, “last fix 14 hours ago”,
and while i’m in europe it places me in the phillipines? :woman_shrugging:
i have it laying in the window for minutes now, but it doesn’t seem to fix on any sattelite…
(even after 4h of waiting)

Connection accurate but it ususally takes up to 10 minutes to pick up location. FP3+ and Samsung Galaxy S8. /e/OS 1.5

This is a feature of Advanced Privacy #Fake my location. AP was introduced about May 2022.


This is a feature of Advanced Privacy #Fake my location . AP was introduced about May 2022.

WHOA!! :see_no_evil::see_no_evil::see_no_evil: That’s it! it says:
Location: FAKE

I have been troubled by gps issues for a couple of versions. Most apps which require location services do not work. Gps position is sometimes found after 20 minutes of driving the car.

In the first versions this wasnt the case. I’m going to read your link, see if that helps.

Edit: For some reason the Mozilla location services button was off and now it works. Weird stuff.

To add my experience. This is the first time I have used /e/ and I installed onto a FP3 last week using the Easy Installer. (July 2023)

Version installed: e_FP3-user 12 SQ3A.220705.004.

GPS was always getting my location within a few miles of me in any map app is used. (Magic earth, Google maps, Waze).

“Advanced privacy > Manage my location”, was set to “User me real location” but I had to keep the that window open for a few minutes for it to pickup correclty.

I’m used to other phones picking up location even indoors, and to start with I was expecting this to do the same, but look like I had to be outside and wait a while for it to correclty locate.