GPS give wrong location by few kilometers


e/OS v2
I have some problem with the GPS on e/OS (was fine on Fairphone OS)
The phone is locating me a few kilometers away from my real position in every apps I tried (Maps, OrganicMaps, GeoVelo…)

I’ve tried to change settings in microG and such but no luck, false position is also deactivated.

In the app “My Location” i get nothing in GPS besides the number of satellites.

Does anyone have an idea of what could be the problem ?



Did you try to reboot your device?

1 Like

Did you turn off th additional meausure for more accurate locating?


1 Like

Tried gpstest?

Does this app confirm that the “Wrong location” comes from Network Location? (This is often quite approximate in some places, in a city may be more accurate.) Similar threads might be with the hashtag gps

Have you tested while you are moving about, preferably over a distance of more than a mile or so.

Hi everyone, sorry I was on vacation and couldn’t respond sooner,

It seems for a weird reason that GPS on fairphone 4 + e/OS is unable to get a location while inside a building, I’ve tried multiple setting in microG location, for now the best one working while inside a building is having everything on. Then the errors is only a few (about 20) meters off.

As soon as I am outside the problem is fixed. I didn’t encounter such issues on Fairphone OS.

The weird reason being that GPS satellite signals tend to not reach inside a building.

With GPS unavailable indoors, location can be approximated via the distance to nearby Wi-Fi networks or cell network towers, if their location is known.
For locations of such being known, several databases exist.

Fairphone OS is Google certified and as such can use the comprehensive Google database for this.
/e/OS used Mozilla’s database, which was inferior for a while now due to a past patent lawsuit or something, and is about to be made unavailable anyway right now, see /e/OS version 2.1 release notes …

“We now provide our own backend location services to take over Mozilla Location Services ending on June 12th”

Thanks that explain why I get better location on e/OS 2.1, I did not had the time to read the release note !