GPS location fails after latest OS update on Fairphone 4

Hi. Since updating today to the latest OS version and turning on (and later turning off) the new “Advanced Privacy” feature I don’t have my correct location for Osmand and Firefox (Google Maps webpage). Both apps have location permission. Any help appreciated.

e_FP4-userdebug 11 RQ3A.211001.001 eng.root.20220905.161747 dev-keys

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

With the gps not working I can’t use any navigation or parking app.

Disable “Hide my location” ? :wink:
Settings app, Advanced Privacy.

1 Like

That’s the first thing I did. I also disabled all of the Advanced Privacy app’s features, forced stop it, restarted. And of course my navigation, parking apps and Firefox have location permission enabled.

The problem started right after updating to the latest e-OS update and enabling the Advanced Privacy app.

I know it’s abvious but do you delete the cache data for those app ?

Maybe another thing to do here

1 Like

Thanks for the tip. Now I deleted the cache of Osmand (navigation app) but it doesn’t help.

I also followed the link you gave. The closest match I could find for the tip there was MicroG settings’ “location modules” option. “Mozilla location services” was off so I turned it on but my position in Osmand is still in the Philippines, and I’m in the Netherlands!

So that sounds just like “Fake my location” within Advanced privacy.

I have found it to stay on after stopping Advanced privacy. So I would try Switch on AP; double check Manage my location and turn it to real; switch off AP; reboot; return and check Manage my location (without turning on AP) is still set to real.

Now test again!

Speculation. AP needs to see Real location before it is used. I do that briefly after an update. When I check mine now, I do have a fixed plausible location and all maps work fine, but that is for the future!


Thanks for that. I just turned on AP as you suggested. (I had turned it off before.) Location was set to ‘real’ so I switched to fake for a while, then back to real and voila! Osmand got my real location. I wonder if it will stay alright, we’ll see.

1 Like

To continue my speculation, the apps know that they are working in Andriod, and expect to collect several sources of free information from Google customers in order to fine tune their first guess. Once it is confirmed, the apps collect their own database of reliable locations.

On /e/ with micro-G we now have two backends but I expect GPS does not play the biggest prioriy unless it is marked as 100% fix.

Once you start travelling and switching towers and other open WiFi channels, the apps own triangulation will become reliable and more useful.


I just don’t understand how we’re supposed to use the location spoofing with the Android Advanced Privacy app.

If we turn it on, all apps that need location permission will dysfunction, so what’s the point?

Why is it not fine-tuned to spoof some suspicious apps but not the necessary ones, like the navigation app…??

As I mentioned my maps are now working with spoofed location. I think it is just about building your own small database of good fixes to triangulate from, then things can work with spoofing, perhaps, or if location is the most important thing for you may have to switch it off. If you are saying, I want the app to know where I am. AP is advanced, as it happens I don’t feel I need advanced.

Once you walk around saying you are in the Philippines for a while, the app’s database is well out of good doubled checked information!

1 Like

Unfortunately it’s not fixed. It was showing the real location for a while but it keeps going back to spoofed location, no matter whether I enable or disable the entire advanced privacy! Can’t I just get rid of the whole advanced privacy thing? It also often crashes.

One advance on my first suggestion would be to get location true, just as before. Reboot check your settings are maintained. Then clear data by
Settings > Apps and Notifications > See all … apps > Top right 3 dot menu > Show system > Advanced privacy > Storage & cache > Clear storage.

Reboot. If Location has stayed off and you keep it off and keep it off Maps may work.

And /or you could navigate to Maps and Clear storage there. This will mean rebuilding your database. To help avoid errors I do not turn Maps on indoors and watch it not working properly. Start it out of doors with mobile data on, walk around, If you have buses or trains with wifi use one in the first day. Save a few positions, switching between mobile data and wifi frequently might help. I recon it takes 24 to 48 hours of active use to get Maps working reliably, but certainly Advanced privacy makes in harder.

I keep it permanently OFF.

You might have noticed in the App info page for Advanced privacy There is a disable button, but on my device it is greyed out.

To try to remove it, at the foot of that page we see Advanced privacy named as foundation.e.advancedprivacy. Now you could follow the guidance in this link to uninstall it from your PC with platform-tools.

Just as reference, although it is not the exact same use case/issue that was discussed here.

I had a FP4 running /e/OS 1.3 stable. Advanced Privacy activated, but with real location and real IP. So only the tracker protection/blocking activated.

Performed an OTA update to /e/OS 1.4 stable. Update completed well. I did not touch (change anything within) my Advanced Privacy settings.

[Indoors] First FP4 did not locate me. E.g. Magic Earth (aka /e/OS-Maps), OsmAnd, YR (a weather app) did not have any information about my position. My - possibly naive - assumption has been, that it should actually be able to locate my position even indoors due to the integrated Mozilla Location Services (supposedly via GSM antennas and WiFi neighborhood).

[Outdoors] Went outside. FP4 was immediately able to locate me and the mentioned apps showed my exact position.

[Indoors] Went back inside. FP4/apps show my rough location, so around 10-20 meters off my actual position, but I guess this is as close as locating is possible without GPS.

Hi guys, does anyone have more info on this issue. I think I have identical situation like klokkentoren. Any way to do some debug without root?

Thanks for the link to how to uninstall pre-installed apps. The location problem continues even when advanced privacy is off and I restart the phone.

A very temporary workaround is to open adv. privacy, set the location to random location, then back to real location. All this time, adv. privacy is off but this is still needed! I made a screen recording but don’t know how to share it here.

I hope that uninstalling advanced privacy will help.

I am not certain what would work for all, but in my experience it seems that Advanced Privacy has to be on to allow the change to Real Location; a notification / toast is seen (but contains too many words to be readable for me); then Advanced Privacy can be switched off; then reboot; one hopes then that everything is set back to “real”; or else try again, with guidance from the AP documentation linked above.

I believe Hide my IP can also be involved with the internet based backends which support GPS – hence my aim to ensure AP is “all off”.

However my experience is with a Samsung, rather than FP4.

I have the same issue on my Samsung S9. I just installed /e/OS a couple of days ago.
Typically at first, Apps worked with the GPS signal and once there is no GPS signal, an inaccurate location from location service is used and not updated anymore, even if GPS signal is again available. In some cases MagicEarth was the only App where the location did not freeze.

Since yesterday I got location working again by disabling all location services (Mozilla and Nominatim) in the MicroG settings. So only GPS is used for the location. After disabling I restarted the phone.

Before, I also tried force stopping Advanced Privacy, but this did not help.

Hope you get it also working and hoping that future releases of /e/ don’t have the issue.


I still have the issue, except right after I switch to spoofed location and back to real location. Some time later however I get my location spoofed again and have to enter AP again. I tried (all?) suggestions above.

Just another idea:
spoofed locations is nothing new, you will find a lot of location spoofing apps around. Common setup: the spoofing app has to be registered in the developer options - as well as AP.
Enter Developer options, choose ‘Select mock location app’ (almost at the end of the list) and select ‘Nothing’ instead of Advanced Privacy. This should enable real locations regardless of the location settings in AP. Hopefully.