GPS not acquiring position - Samsung S7 -

Hello, i am reaching out because i am struggling to get gps working properly on my phone since i switch to this new android. I have tried differents apps but it doesn’t seems to make any differences, the apps always locate me around my house but the position doesn’t seems to refresh when i am moving.
After doing some researches i have tried mozilla stumbler to potentially try to figure out where does the problem comes from but it seems that my phone doesn’t catch any signal. I tried it indoor and outdoor no difference. I have also tried to update my maps ins OSM, but same result. It seems that some people have solve their issue using the apps FasterGPS but it requires root priviledges which i don’t have. I also change the user profile in case some settings such as power saving was interfering with the gps, but no result at all.

Does anyone have clue on how to solve this issue?

my phone is a galaxy S7 (SM-G930F), i am running the version 7.1.2 and the lienagAPI is called Guava (i don’t if that helps).

thank you

Hello, welcome in the community :slight_smile:

Did you try to change the location mode ?

Hi,
Try GPSTest : https://f-droid.org/en/packages/com.android.gpstest.osmdroid/
(F-Droid is available from /e/ Apps).

i have tried, and seems to behave the same way : th position doesn’t get refreshed.

Alse i tried the GPS Test apps, like mozilla stumbler it doesn’t seems to find any signal.