GPS not working anymore after OS update - No location found



As I reported here, the location function does not work anymore on my FP4 since the update to 1.14-s.

  • Maps (magicearth), or the map displayed in advanced privacy, don’t find me,
  • or they locate me quite far off - that is when wifi or 4G are on, it seems.
  • GPSTest shows that no satellite can be found, see the two screenshots below.
  • It seems the location function tends to turn off by itself after a while
  • The very first time I started Maps after the update, I got a pop up complaining about gogle services not being on (I think, or something of that kind as far as I can recall).

Testing conditions disclaimer:

  • while testing from outside, without a roof on my head
  • with Advanced Privacy off for location spoofing (give true location)
  • GPSTest, Maps and OrganicMaps are granted access to my location while in use.

Note: It’s not the first time I am experiencing this. I have had the phone for about a month. I directly updated it to 1.13 and then the same thing was happening. I did a factory reboot, and then it started working well (except for inside). It was working perfectly fine the last 2 weeks since then. Crashed again after the 1.14 update.

I hope someone can understand what’s the reason for that… :pray: No geolocation really sucks (and I am travelling abroad next week, don’t want to reset my phone again…).

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


On your screenshot WiFi is on. Can you see the same behavior with only 4G and running GPSTest for 15-20 mn?


This morning here is what I observed with GPS test and organicmaps, when walking outside:

  • no wifi, no 4G = no signal (0/10 satellites on GPSTest) for about 5-10 min then suddenly it got a location, but that looked clearly off on organic maps (200 m at least?)
  • no wifi, 4G on = signal gets better and better in a minute or so, and then good, with about 10 m precision or better
  • no wifi, 4G turned off from signal obtained before = kept following rather well.

(I have a few screenshots of GPSTest if needed)

1 Like

Hello guys,

This is exactly what happens on my Murena One after the exact same update. Everything described in this post happens to me as well after last update that moved to Android 12; so I believe this is not a Fair Phone specific issue. I use Murena One with e OS 1.14-s-20230816320616-stable-one.

Can somebody look into this, I traveled 1000 km today and location is unusable, I had to use another phone… :frowning:

Bought it 2 weeks ago, everything worked perfectly before the update, I traveled ~600 km with no issues, maps apps worked wonderfully.

This is a screen recording on how it behaved today:

It is unusable. Also location and location precision are turned on.

Part of the issues may be related to the location stack used in microG 0.2.28 though I believe there have been (should have been?) some improvements with it in latest 1.14 build.
Not really sure as I stay away from 0.2.28 for the time being.

Anyway, another tool to use is SatStat. Its map screen gives a good indication of GPS and network accuracy (when they are working).

The red marker is GPS, blue is network. Each will have a similarly colored circle showimg the area it covers.
In the screenshot below the GPS is at my house and the circle is really small. Good.
Network location is nearby but mostly it was across the street. Its location kept movimg. For a brief moment it was also at my house.

When I was on the initial release of microG 0.2.28 the network location was across the city and its circle covered all of the county. Not good. The baked-in Mozilla backend wasn’t very good.
Orqanic Maps, when using only GPS, would initially start far off before jumpihg io where I am.

Note: The shot is from a OnePlus 8T, crDroid A11 with microG 0.2.27. It did have 0.2.28 before I knew better. :grin:

On my Teracube emerald with /e/OS 1.14-r (microG downgraded to 0.2.27) the results were similar but the networking was a bit farther away. Soon as I disabled the Mozilla backend it moved closer to the house, same as on the OP8T.

Do I understand correctly, could the problem be because of MicroG 2.2.28? I use (bb5c25b-noen).

Could a possible workaround be downgrading to MicroG 2.2.27?

GPS is essenially standalone with no connection to microG as far as that working or not.

When the GPS can’t get a fix one hopes that network location is working well enough to fallback on. I noticed some additional location/backend settings in 0.2.28 (on /e/ anyway) that weren’t there when I first tried it back in June. Some bits from Local NLP I believe. Maybe it’s a little better now.

Does that mean that GPS not working correctly is purely an OS related matter and there is nothing that can be done other that wait for an OS update that fixes the issue?


An update from my side: it seems to have been solved by… putting a new (recent) SIM card.

Because, for my case, there was one extra issue I had not listed yet: internet via 4G was not working anymore either (and since I almost never use it, it took me some time to realise).

Currently I am abroad, in a very dense city, and geolocation (in organic map) has been working every time I have tried (3 times in 2 days), without having to turn on wifi or 4G. Let’s see if that keeps going when I get back home.

=> maybe maybe @iuliuh you are in the same situation?

1 Like

@valerieos I will definitely try it. I’m currently in Croatia, need to see how I could get a SIM card with 4G; but yes, when I was travelling here in crouded cities, location discovery was chaotic and it was oftwn jumping from street to street in wrong ways.

But I am very curious, what could a SIM card have to do with this? Isn’t the location service agnostic of this?

Note1: for short periods of time it works ok; if I stay 1-2 days in the same place then I travel again, it works well; however, just out of nowhere it stops working and never recovers.

Note2: potentially stupid question: could it be that Murena One doesn’t support 4g?

Or LTE means 4g?

Yes, in this context.

This topic was automatically closed after 60 days. New replies are no longer allowed.