GPS problems on latest build

Recently, I’ve installed the latest e/OS build on my redmi note 9S with no problems, however, I’ve tried to use GPS for navigation now and at first, I couldn’t get a gps signal at all. So I did some digging, rooted my phone with magisk (by patching the boot.img and flashing it through adb) and used fasterGPS to change the NTP server. I then used a file explorer to check if the change applied and it didn’t, but now I at least get GPS signal at all. I don’t know why that worked but that’s not the problem here; the problem here is that the reported GPS location is wrong. It shows I’m in a very different city (still within the same country though) than where I actually am.

How would I go about fixing this? I assume it’s a wrongly configured location offset, but I haven’t tried actually going outside and seeing if tracking works, I’ll likely do that tomorrow.

Any help would be appreciated, thanks!

Have you checked that “Fake my Location” is turned off under Advanced Privacy? It sounds like it may be set so that it is not using your real location.