Green tint when taking pictures in HDR mode (Samsung Galaxy S7 SM-930F)

Hello /e/Community,

I have a problem using OpenCamera, when I take HDR pictures, the photo as a strong green tint.

This is quite problematic as I used to take a lot of picture using this mode on my former phone. Besides, it appears that the quality of the photo is not as good as before… Yet, it is a 12 MP camera !

Thanks for your cooperation and your help !

Do have the same issue when using an alternative camera app?

No, I tried via the Open camera on the App Lounge, and it doesn’t seem to bug… But the app is really slow and is lagging, so I deleted it and the others apps don’t offer this mode.

I assume the green tint is a specific problem linked to the Opencamera included in the /e/OS package… It has been reported on S7 since the v1.4 release. Nevertheless, I’m on 1.17-q, and it was already bugged when on 1.16.

If you have some alternative open-source camera app to advise me, I would appreciate it very much. Besides, as I didn’t make a lot of test, I don’t really know if some specifics apps are bugging too, or if this is the only one.

I don’t have that issue with my SM-G930F, neither with onboard eOS-camera-app nor with grapheneOS secure camera (which does not offer HDR-option afaik)

Can you send me your Opencamera or phone configuration in order for me to identify the issue (of course if it’s come from a setting) ? I’ve downloaded the grapheneOS secure camera, and it’s quicker than the /e/OS camera. I’m gonna keep it a few days in order to have a quick camera, but there are fewer functionalities on this app than on the /e/OS camera.
Thanks for your help @obacht

A useful trick with my Samsung is to use

Camera settings (top right) > scroll to bottom > Settings manager > Reset settings.

I believe that with my Samsung one can call up a “non sustainable” setting (perhaps to cope with low light) then at subsequent exposures the camera deviates further from the logical setting. No idea if this could have a bearing on the green tinge but proprietary firmware may play a part.

I think you know that Camera app v1.51.1 Code 87 on 1.17 is the same app as OpenCamera v1.52 Code 88 offered on App Lounge ?
I also use Secure Camera from Graphene.

1 Like

I mostly use graphene´s Secure Camera because it is faster and the settings seem less complex and thus more straightforward for my usecase and abilities as a photographer…

eOS-camera in my case is version 1.51.1, fork of open camera
From what I recall I never tweaked the settings very much - so it should be mostly default settings, I only tweaked the HDR settings for the test purpose and now they are:

  • save all pics of the HDR-photo: OFF
  • HDR tonemapping: default
  • HDR contrast-enhancement: intelligent
  • 3 pics per bracketing
  • 2 apperture-steps per bracketing

resetting the camera as proposed by @aibd sounds like a good idea
but in that menu I also found the option to save camera-settings, I´ll try to send you my XML for test purpose via PM, better save yours before trying mine :slight_smile:

Hello @aibd,

I did what you told me, and it’s working well now !! No green tint anymore. I notice now that the camera wasn’t taking all the 3 photos before resetting the settings. It might come from this.
Anyway, I didn’t know that it was the same camera, but it appears to be obvious seeing that the bug I had was reported in the v1.5 feedback. By the way, some of my photo mode disappeared… I don’t know why but as I didn’t use them it’s not that bad

Thank you two for your help !!

1 Like

Thanks for your help and for sending me your configuration, I will compare it with mine. I love changing the settings in order to have the best custom camera possible, but sometimes it plays me tricks… Might come from the last 2 settings you’re talking about, because I saw the others and they were as you say.

1 Like

Hello @aibd and @obacht,

I successfully reset my settings and I didn’t have any problems anymore with the green tint on the moment. But I notice something, that each time I touch my settings the bug comes again. I guess this is coming from the source code. That’s quite annoying as I need to let the default configuration. Do you know if this is a known issue ?

This topic was automatically closed after 90 days. New replies are no longer allowed.