GS290 flash error

I’m trying to install /e/ on GS290. I’m on Debian 10. I followed all the procedures carefully and verified hashes. I get this error:

$ fastboot flash --disable-verity --disable-verification boot boot.img
terminating with uncaught exception of type std::out_of_range: basic_string

Any ideas?

Thank you

I couldn’t find any directions to fix it. I decided to use easy installer on win10, which worked perfectly. I am very curious about the error. If anyone has any information on this I would be happy. Thank you

Did you use the right version of fastboot? I think I had the same error because I used a newer version of it.

I have got the error on this version of fastboot:

fastboot version 31.0.2-7242960

Thank you

I had exactly the same error, I tried to get round it several times but failed. I went down several rabbit holes and and then went to the Easy Installer.

Install TWRP on a GS290

Please see here : [SOLVED] Fastboot flash Boot shows uncaught exception of type std::out_of_range: basic_string - #10 by juergen

… and Gigaset GS290 - Installation - Problem - #9 by aibd