GS290 - is there a way to get back to factory Android?

For the GS290 there is (apparently) no TWRP (yet).

Is there any other way to get back to the GS290 factory settings IF that would be required after installing /e/ ?
Thanks!

After installation of /e/, when starting the phone, there is a message on the Gigaset start screen, in a very small font:
"Orange state.
"Your device has been unlocked and can’t be trusted
“Your device will boot in 5 seconds”

  • Should that be part of the instructions?
  • Is there a way to get rid of this message and the start-delay it causes?

This message shows up on all devices with unlocked boot loader. Ignore it.

2 Likes

Dears,

looking at the Name if this threat, I was hoping to find an info if it is possible to install the stock ROM from the gigaset gs290. If yes,how?

This phone us intriguing but I would fell more intruiged when there would be a way back, just in case.

Best regards,

1 Like

I haven’t found a way to do this. I assume that this is dependent on the availability of TWRP, and that is not available for the GS290.

In the mean time I have taken the risk and installed /e/OS anyhow on my GS290. I am quite happy with it.

Pl check the documentation given here this was tested on a windows PC

2 Likes

Thanks @Manoj! I will give it a try

/e/ uses the source code from Lineage-Recovery for its own GS290 eRecovery. The feature set is much smaller than TWRP, but it is well equipped for OTA update management.

To get back to your initial question:

To get back “to the GS290 factory settings” you need the orignal Gigaset GS290 Stock Android 9 or better Stock 10 once. I didn’t find a download option, did you?

To flash the software you can use the SPFlash Tool for MTK SmartPhones. SP Flash Tool is the MediaTek equivalent of low-level flashing like Odin3 on Windows on Samsung devices.

2 Likes

I am confused.

I thought that Manoj had explained how to revert to the stock ROM of the GS290:

Or am I missing something?

If you can cope with the “explanation”, everything is okay. Only for me it is misleading.

By way of introduction, it is a curosity for me that /e/ has a /e/ documentation exclusively for Windows users. The rule is that it talks about Linux and its derivatives. Well, I see this as progress.

Ambiguous in the /e/ documentation is for me the designation “downgraded to android 10”. Is this meant - from AOSP Android 10 e-0.13-q to Stock Android™10?

Downgrade is the opposite process to upgrade correspondingly so a downgrade from a higher version to a lower.version. For me, Stock Android™ 10 isn’t a lower OS version than /e/OS build dev OS version ‘Q’ but a completely different OS on the same starting point AOSP Android 10.

The Gigaset GS290 shipped with Stock Android 9 ‘Pie’ in 2019, meanwhile with Stock Android™ 10. If the /e/ documentation would say “Now it will be downgraded to android 9” that would be for me the term “downgrade” a bit more understandable, whereas I would not use the term downgrade when changing two different OSes.

Of course, you first need to find a download option for GS290 Stock Android 9 or 10 in order to switch from /e/ OS to GS290 Stock Android™. In the meantime, do you know where the official Gigaset GS 290 Stock Android™ is available for download? We should have it in the pipeline, just in case.

1 Like

My confusion is: there are instructions for going back to stock android ( given here ) , but is that complete? Or do we ALSO need to have “stock Android for the GS290” downloaded. There is no mention of a separate download in those instructions.

And no, I do not know where to acquire that file.

Yeah, of course we need the original Gigaset firmware Stock Android™ to flash the GS290 back to original Gigaset delivery state. Not for nothing I already asked two if download possibilities are known!

The /e/ documentation describes …

In scatter file select MT6763_Android_scatter.txt inside the extracted firmware

To be able to do that, we need a 1.2 GB to 2.0 GB GIGASET_GS290_*.zip file

1 Like

My research has led me to several official stock ROM’s for Gigaset smartphones, including the GX290 with Gigaset official stock firmware 10.0 V11 20200813 - but I can’t find a download link for the GS290.

For me, this gives the impression that the company Gigaset Communications GmbH isn’t willing to make the official stock firmware for the GS290 freely available to everyone. For marketing reasons or why else?

1 Like

in the attached link you will find a download page for a android 10 firmware. it worked on my volla phone, and will as well work on the original gs290, im sure. (use it on your own risk :slight_smile: ) Installing /e/OS after removing UbuntuTouch on the GS290
Maybe @Manoj can add the download link to the document https://doc.e.foundation/pages/revert_e_GS290_windows he posted previously?

Thanks for pointing that out. Will add the link to the documentation.

2 Likes

@1n4ts, thanks for the link.

An unofficial download source for an official stock Android firmware. This fits well with my Gigaset research, which says that Gigaset rarely distributes updates for its smartphones. Accordingly, the devices mostly remain on the Android version they were shipped with.

Gigaset surprised users with an OTA update of the GX290 and the GS290 to Android 10. However, users had to wait almost a year for this update. I see a bleak future for the GS290 under stock Android. It remains to be seen whether /e/ will have the strength to provide updates permanently. When I think of the sad history of the former Pr/e/mium devices Galaxy S7 / S7 Edge, the chances for the GS290 are not particularly good.