GS290 - is there a way to get back to factory Android?

@1n4ts, thanks for the link.

An unofficial download source for an official stock Android firmware. This fits well with my Gigaset research, which says that Gigaset rarely distributes updates for its smartphones. Accordingly, the devices mostly remain on the Android version they were shipped with.

Gigaset surprised users with an OTA update of the GX290 and the GS290 to Android 10. However, users had to wait almost a year for this update. I see a bleak future for the GS290 under stock Android. It remains to be seen whether /e/ will have the strength to provide updates permanently. When I think of the sad history of the former Pr/e/mium devices Galaxy S7 / S7 Edge, the chances for the GS290 are not particularly good.

1 Like

I tried to install unzipped files with SPFlashTool v5.2036_Win, but it failed because 2 files aren’t present:


For a repair of a failed /e/ OS ‘Q’ installation with the /e/asy installer (v.0.12-beta) this would be an important tool.

1 Like

Maybe you want to try one version below yours. I never used it on windows since I got into trouble finding the right drivers. That said, on all Linux installs I never ran into the problem with missing download agent.

1 Like

I would do that, only - I can’t find any trustworthy download options. Where did you get original firmware?

1 Like

I only have the one I posted above. Officially my phone e is a volla phone (with vollaOS - still is android 9). Volla state that it is not identical with GS290 - yet the GS290 firmware works. Is it big of an issue, if you flashed the mentioned firmware previously to flashing to /e/?
If so,I’d like to know about it as well.

1 Like

With offical smart phone flash tool I couldn’t flash the above firmware. So, coming from Stock Android 9-Pie, I did several OTA updates until the Stock Android 10 December 2020.

Then when the /e/asy installer failed and crippled my GS290, I flashed .img files via fastboot and was able to escape the /e/bootloop. But I don’t see this is an optimal solution for a user à la “Mom and Dad”.

1 Like

Its kinda OT but, could you update your device any further than the IMG that is mentioned in the flashing instruction?
There’s an GS290 Updater app, but that is not willing to be installed on my device.

1 Like

Installing /e/ OS ‘Q’ /e/ according to the /e/documentation from Install /e/ works flawlessly. The /e/asy installer should also work if correct files are downloaded.

I still wonder why the manufacturer Gigaset is so reluctant to provide official GS290 firmware as a legal download. This isn’t typical for the ‘Made in Germany’ brand, is it?

1 Like

Hello, I tried to install the Android 10 firmware to revert to Android and it’s not working, here is the error :

And now, I can’t turn on my Gigaset GS290 anymore… Do you have any solution?

Thank you for your time :slight_smile:

1 Like

It would probably have been better if you had not installed the first position [.] preloader. But it’s what it is. I know this error message too - unfortunately, because since I physically killed my GS290.

1 Like

Alright, thank you for your reply… I’ll bring my phone to a store to see if they can do something, because there is still the sound of active connection when I plug it to my computer.

1 Like

have you tried that ?
fastboot flash --disable-verity --disable-verification boot boot.img

1 Like

Just for others who read along later, here is a screenshot from this mtktool version of sp-flashtool.

The screenshot shows the warning: Now Untick the Preloader option (flashing the preloader.bin can brick the device).

Message to reader, this may not be the manual for your latest version of SP Flash Tool. But it shows the importance of

Reading The Manual.

3 Likes

but I can’t access the smartphone. It is completly bricked. So there is no where to type commandos to.

But thank you

I just got mine and in the manual it says the phone contains Open Source software that can be downloaded from the main page.

Intrigued, i checked the URL provided in the manual:
https://www.gigaset.com/es_es/cms/lp/open-source.html

There are zip files, several GB in size, for almost every of their device models, GS290 and GS290X included.

I downloaded mine (14GB in size) and when i checked it i saw this:

I’m no android expert, but doesn’t this look like the full stock rom? Can anyone confirm? I mean… if the stock rom contains 14GB worth of Open Source code…

Also, checking under Settings>System>About phone>Legal, as stated in the manual, i see an endless list of files, most of them indicated to come from the Android Open Source Project.

As i said, i haven’t even worked on custom roms so i’m not an expert, but it looks like it uses Open Source Android as a base.

3 Likes

Hi @gunmask welcome and what a stunning first post!

This is correct and known. What is new to me is that they have at last published this, I see also an international edition.

I have no GS290 but thank you for sharing this.

I seem to have been over hopeful. …

this is the source code, you will need the firmware, built and signed by gigaset

1 Like

Thank you. This link is very helpfull. But I do not now which number I should use and downloud when I follow the link and come to the Gigaset custompage for firmware DL.

So anyone can build for the rugged model ?

1 Like

Excuse me for not being updated and have read all the new topics. But it has being a while and I had to learn Fedora linux and some basics about computers before retry to reinstall my bricked GS290 which has being in the draw since I bricked it while using Easy install but by mistake forgot to update to Android 10 from the 9 version which the Gigaset GS290 came with from Conrad e-store. Before bying a new ready installed from the Efoundation shop. I would know if someone had the same experience or if there is new updates or knowledge of how to reinstall the factory OEM by Gigaset. The link you @piero posted seems to lead to which OS OEM I am looking for but I am in doubt of which one I shoul choose and how to flash and the other procedures from here.

Please help