GS290 suddenly in Recovery Mode after 8 months of usage

Hi,

when I switch on my Gigaset GS290 phone, it shows a screen saying “e Recovery Version 1.2”. Using the options provided there I haven’t been able to start up the phone normally again, so the phone is unusable at the moment. The problem occured without any intentional interaction from my side: the phone was working, I put it in my pocket, I did some work around the house, I took the phone out of my pocket after a few hours, it was turned off. I turned it on, it showed the Recovery screen.

I bought the phone in December 2021 with /e/ preinstalled. It was working fine and I was happy with it. A first problem occured around the introduction of version 1.0 of the /e/ operating system: GPS stopped working. It always showed a static location in the Philippines, while I was moving in Europe. Not sure if these problems are related.

Regarding the options on the Recovery screen:
“Reboot now” on the Recovery screen brings back the same Recovery screen.
“Advanced → Reboot to bootloader” leads to a black screen with tiny white text in the bottom left saying “FASTBOOT mode…”, which stays for hours without anything happening.
“Apply update” leads to an option to apply an update from ADB. I haven’t tried this one.

  • Does anyone have an idea for what reasons this problem might have appreared?
  • Does anyone have an idea how to get the phone working again, or at least to rescue some data like pictures that were taken using the phone?

Hello,
Have you tried to wipe cache and reboot ?

Hello,
Many thanks for your reply! I haven’t wiped the cache yet, will try it…

Hello,
I could not find an option to wipe cache in the Recovery menu. Can you please guide me how to do it?

@piero just to notify you that I couldn’t find the option to wipe cache. Not sure whether you were notified about my reply above.

I cannot plug my PC to restore TWRP, so i don’t what to install the recovery-e on my device, it should be under “advanced” menu

Edit : after a quick searchhon the internet, it seems there no feature in the recovery-e to do that as TWRP it became useless because modern phone are encrypted…

Please can you clarify the /e/ version on your device previously and the version to which you hoped to update?

Hello @piero,
OK, thanks for searching. Indeed it seems to be absent from recovery-e. Does it make sense to flash TWRP on the phone and then wipe the cache?

Hello @aibd,
The recovery screen appeared suprisingly to me without any intentional interaction. The phone had been working normally (except broken GPS) before I put it into my pocket. When I took it out a few hours later, it showed the recovery screen. /e/ OS was definitely above version 1.0, I think 1.1 or 1.2. The recovery screen says e Recovery Version 1.2; not sure whether these versions are synchronized.

This was what I hoped to find out – they can get out of sync!

There was not an official TWRP published and there are reports that an unofficial build was taken down. Right now I am not aware of a source of TWRP.

It is always possible that either the system or the recovery are corrupted in some way, from what you say we don’t know which.

Easiest things first – you might double check whether /e/ recovery has any ability to specifically boot to system. If you were positive that if you boot to system only Recovery loads, this points to damaged system.

Try to connect the device to your PC with the phone in Recovery mode. Hopefully you can read internal storage and make a full or partial copy of your stuff.

What next?

If you can get a backup first you could consider doing a Factory reset from /e/ Recovery. (I am not a user of /e/ Recovery, I do not know for certain that Factory reset exists.) In the event of Factory reset you expect to be returned to your /e/ version, all self-installed apps will be gone as will the data in them and your stuff in internal storage – so not to be done lightly.

Another option might cause less damage – flash the /e/ system for the device. Install /e/OS on a Gigaset GS290 - “GS290”. As a purchased phone you will need to use the stable ROM.

Regarding Apply update and fastboot, these are other specific jobs that are not appropriate right now.

1 Like