[GSI] Q-GSI --- new version download location. See post 73

Glad that you will continue to make your builds for now.

Concerning official GSI build, I’ve installed it cleanly (format data, wipe everything except external, and wipe caches after flashed).
I have to confess that I modify builds before flashing them (remove some apps, and part of firmwares and librairies related to bluetooth, wifi and gps) but my mods work fine with your builds and some LineageOS based roms (unofficial LOS17.1 and crDroid 6.x for example). I don’t know why it doesn’t work with official /e/ GSI.
I’ll be waiting feedbacks from trefix and others to see if it’s related to my mods or if a3y17lte needs something missing in the official build to boot/work properly.

EDIT : Without any mods Official GSI image boots and seems to work (not fully tested).
So my mods are the cause of bootloop although they work on this unofficial /e/ build, LOS 17.1 and crDroid 6.x. I don’t know why, but that’s a problem I have to fix myself. Waiting for more tests from other users and for the moment I will use this Unofficial build which is perfect for me.

Hi,
I m using 0.18 q (unofficial) on my Mido now.
Now I want to install /e/ Os (official) for regular use. Can you guide me how to uninstall 0.18 q unofficial and install 0.17 n Official Version of /e/ ?
Thanks in advance

download is missing from the original location, and the other link requires an username and password, how do we access these gsis?

https://doc.e.foundation/how-tos/install-GSI

Once you know which system image you need, download it

Is this only available on treble enable devices?
My a3y17lte is not Treble enabled.
I have tried this method but cannot get it to work.
booting to bootloader doesn’t work on my device for some reason ( always goes straight to normal boot or gives error)
tried installing ZIP with OrangeFox and TWRP, Both give error for invalid zip format.

not 100% sure, but i think @trefix or @OneThumb may help you preparing your device for treble

Yes, Generic System Images (GSI) are only for Treble-enabled devices, i.e. devices initially sold with Android 8 or above, IIRC. Some devices that weren’t initially sold with Android 8+ can be modified to become Treble-enabled, and apparently your a3y17lte may be eligible : [TREBLE][9.0][arm64] Project Treble for Galaxy A3 2017 V1.0 | XDA Forums

But please read the known bugs section in this thread that may contain dealbreakers for you.

Yes, you have to “treblize” your A3 2017. I think i’ve used this repartitioner script : [TOOL][A320FL/F/Y] Repartition script for vendor support | XDA Forums
This will make a system partition and a vendor partiton, both separated from each other. The GSI image is the system image for the system partition, so you have to have a vendor partition from a rom. For example, i’m using the crDroid v6.17 vendor partition (now it’s 6.21) : [ROM][10][ARM64][A320] crDroid v6.21 for Galaxy A3 2017 [10.08.2021] | XDA Forums
In this crDroid thread, the link to the OrangeFox is wrong, but there is a new Repartitioner Script (2021) link. I haven’t used it.
Just after flashing a custom recovery (TWRP or OrangeFox) you have to do a backup of your EFS partition (save it on your SD card, not on the internal memory of the phone, and make a copy on your computer to be safe).
With TWRP you will maybe have some data partition errors and will have to wipe data partition every time you will go into recovery mode. So i’m using OrangeFox (flashed after TWRP). But I believe you can’t flash an .img on a specific partition with OrangeFox, maybe I’m wrong. And i never have managed to sideload with my A3 2017 on my computer.
The image you will need to flash on your A3, when you will have treblized it, is an Arm64 A/B image.
I make some changes in the original GSI image (i uncompress the .xz file to extract the .img system file, rename it in “system.img” and I use SuperR’s Kitchen to extract all the files of the system.img). I do my mods on the extracted files and then i repack it (still with SuperR’s Kitchen) in the traditional format of most of custom roms (like crDroid), so the original system.img becomes 3 files : system.new.dat.br + system.patch.dat + system.transfer.list
like in the crDroid zip rom. Then i put these 3 files in the crDroid zip to replace the 3 original files of this rom and I flash this modified zip with OrangeFox. [In fact, I’ve modified the script of the zip to just flash the system partition files, not the vendor files, since I already have the vendor partition and I don’t update it, it’s quicker.] But I’m a “newbie”, so I’m not really a good professor for you, and the whole process is not fresh in my head.

2 Likes

Hi,

I could install the crdroid zip,
Yet with any of the GSI for /e/OS I get the message:

invalid zip file format! for all of them.
I have no problems with lineage GSI or Crdroid.
But i really want to use /e/OS

Anybody?

Hello.

I used successfully Arm64 A/B.

Did you unzip .img.xz file to .img before flash?
What method did you use for flash (sideload, sdcard)?
What’s your recovery? I had to use orangefox…

Good luck!

I downloaded the ZIP file from the location of @piero

I used OrangeFox to wipe device and after copying the zipfile to phone i start the process by clicking on the zip file.
Then i get an error- message: invalid zip file format!

I think you are downloading .xz files, which are zipped. You need to unzip the .xz file and use whatever is inside

1 Like

it is a .zip file that i downloaded.
I have already tried unzipping it and then tried installing it (system.img)
but then the message is “Size of image is larger than target device”

Ok so i repartitioned system so it is big enough tutorial here
I have succesfully flashed the unzipped file,
But now it still says no OS has been installed
Do i need to install somthing on the vendor partition?

It is a common TWRP message as you have wiped /system partition, dont care about it,
if you have installed or sideloaded the /e/zip
You can reboot the phone and see the /e/ bouncing…

Hi,
Do you still have a location where we can find your builds?
Because I can’t have my camera app working (org.lineageos.snap) with official build, whereas with yours it worked fine. Or any idea why it doesn’t work? I’ve tried several versions of snap without success. Open Camera (or eOs fork) doesn’t give photos as sharp as Lineage snap app, neither footej in non premium version.

A post was split to a new topic: Are new builds being made