[GSI] Q-GSI --- new version download location. See post 73

Always when flashing a new Android version a clean flash is best choice.
So do following:

  1. Format data with twrp or with ‘fastboot -w’
  2. Flash GSI with ‘fastboot flash system GSI.img’ (this will erase /system)
  3. On some devices you have to flash vbmeta.img with ‘fastboot flash vbmeta vbmeta.img’
  4. Reboot system
    On bootloop you can try installing permissiver.zip with TWRP install
1 Like

I think you can flash anytime Miui stock rom. So the chance to brick your device is like zerro

1 Like

My Xiaomi MI A2 system didn’t work 100% correctly after today’s flash torture. Therefore I installed Stock Android 10 ‘Q’ as first step.

The second step follows immediately: Tarahh …

eOS-Q-Full-_arm64_bvS-20201017_by_harvey186 - Kopie

Jippie-Ja-Jeh, @harvey186’s 99.99% de-google-d /e/ OS Q-GSI starts quickly on my Xiaomi MI A2 without any complications.

@harvey186, thanks for everything(!)

Nice, always welcome :+1::+1::+1:

17/10 eOS build gsi is working with Samsung A8+! Thanks. Earlier one had sdcard issue. May use it as daily driver.

1 Like

This is my second test with now ‘treblezied’ Galaxy S7 SM-G930F ‘herolte’.@harvey186’s build eOS-Q-Full-_arm64_avS-20201017 booted up with the first start, queried the SIM pin and wirelessly connected to Wi-Fi 802.11ac.



Figure 5 and 6: In Dark Mode the directory name on the microSD card is not recognized because of the font color.

The quirk “only restarting the phone after about 10 minutes” as known from the first test is also present here. What could be the reason for this?

no real treble device which are treblized with patches will often have some issues. My Mi5sPlus for example is randomly rebooting

Yes, that it is due to my hardware configuration is most likely. I know your GSI ROMs by now and know that they work very well on official ‘Treble Project ready’ devices. I will try to make the S7 ready in a different way ‘Treble Project ready’.

1 Like

November, 11th:

  • Latest sources
  • latest MicroG version (with traching API)
  • without Setup Wizzard (removed because boot will crash)

Hello @harvey186,

I still have problems with WLAN, today I installed your latest /e/ GSI version.
With the “old” version I also had problems with WLAN, after a few days it didn’t work anymore, even switching it off and on via the icon didn’t bring a solution. A reboot and the WLAN was working again.
Today, after the update, I noticed that the WLAN is supposedly not connected, I connected “manually” to the WLAN network again, but the display came up anyway, not connected, but it worked anyway.
After a restart I have to connect “manually” again, then I get the message that it is not connected, but the connection is still working.

This should be just for your information, I want to use as little WLAN as possible anyway, except when downloading large files and then turn it off again immediately.


  1. Pls remove the advertisment

  2. Pls download latest from https://reuthernet.at/GSI

Or have you used that location?

I fear the issue depends in your firmware. Is it Android 10 firmware?

It was about the WLAN icon in the status bar, I cut it once.
So it is displayed and WLAN is still there.

It is the version from 11.11., your version from https://reuthernet.at/GSI

Why don’t try my LeOS R? You have nothing to loose (if you have a data backup) :wink:


i am the one where your LeOS is not running, my note 9pro always boots into fastboot afterwards…

Ah, OK, Sorry, but I’m serving too much users to remember everyone :wink:

1 Like

Hi @harvey, I know that your focus is on AOSP 11 ‘R’. Nevertheless, an updated version of your eOS-Q-Full-_arm64_bvS with Android Security Patch Level 5 December 2020 or soon with 5 Janauar 2021 would be a fine thing - please! :))

Hi, SuzieQ, I’m sorry, I’m out of building eOS.
But another user (@anon26953564) is building eOS GSI. He is waiting of dec. 5th patches, but still not integrated in eOS sources.


I have built and installed a build on the phone every day now, unfortunately there was no December 2020 security update integrated yet.
If you still want to update, you can download the latest build from yesterday here:

Thanks for the info :slight_smile:

by the way, after repo sync you can look into build/make/core/version_defaults.mk. Search the file for security_patch. There you will find the date of patch.

1 Like