Hard reset possible?


I just have made a BIG mistake: I was trying to get out of the bootloop issue, I was ready to try a factory-reset and reinstall everything… but I messed up with partitions (in my last attempt before I wanted to do the reset) using adb shell, and I just saw that after hitting Reboot.

Now my FP3 does not respond at all: i.e. no boot with Power (not even Fairphone logo), no fastboot with Power+Volume -, and no recovery mode with Power+Volume +:scream: :sob:

Is there anything I can do to hard factory reset?
Or is there nothing else than sending it back to Fairphone, where they might have the tools to completely factory reset it, or replace the main board?

PS: I know I’ve been stupid. No need to remind it (except if you provide a true answer at the same time :wink:).

I tried to replace the boot partition using dd in adb shell.
I made a copy of the mmcblk0p21 file (corresponding to boot_a in my case), then tried

dd if=boot.img of=/dev/block/mmcblk0p21

and I got an error saying that the file could not be written due to a lack of space (which was clearly not a lack of space on the phone, so I suppose it was just the partition size that made it say that).
And so I thought that the operation had completely been aborted, and that the original mmcblk0p file was intact, so I did not try to revert (and I don’t know if that would have been possible, after all).

I think a better place to ask is the Fairphone forum.

1 Like

Yes, I found it afterwards, thank you.

Currently it doesn’t work, but I’ll ask in this topic if needed.

Update for anyone in this situation

I followed the guide provided in the above link, and that worked for me.
I had to perform the phone disassembly, detailed in the answers.

Thanks again!

1 Like