Having trouble flashing /e/ OS GSI on to Ulefone power armor 13

Hi everyone.

I just got a Ulefone power armor 13 that I’ve been trying to degoogle, I chose the phone for it’s low cost, big battery, large screen and rugged design. The downside to using a less common is the limited choices for an alternitive OS, this put me of for a while though when I found out about GSI’s I decided to take the plunge.

I’ve done my best to follow the instructions to install/ flash the os on this webpage How to /e/OS on a non supported device? and used the system images from this webpage /e/ image ROM download after checking my phones architecture as per the instructions.

After some trial and error I got one system image to install/flash (I think!) but the phone will only boot to recovery, obviously something is not right but I lack the know how to tell whats wrong and how to fix it.

Could anyone here help out a first timer figure this out?

Many thanks

This is what I’ve done in a Redmi Note 9 (with super partition)

***************** Backup (Optional)
adb backup -apk -obb -all -nosystem

adb reboot bootloader
fastboot --disable-verification --disable-verity flash vbmeta vbmeta.img
fastboot reboot fastboot

In fastbootd:

fastboot erase system
fastboot flash system gsi.img
fastboot -w # optional, if no boot
fastboot reboot

1 Like


Thanks for the suggestion, unfortunately that command sequence didn’t work on any of the system images.

any log output from the process? screenshot of treble info?

I kind of suspect device partitioning playing a role. For some users/devices erasing the product_a or _b partition (depending on currently active) helps in making space for the system partition write.

Is it true that the Ulefone Power Armor 13 comes with stock Android 11? If so, then unfortunately /e/OS ‘Q’ (Android 10) will not work.

1 Like

Hi Jazzda & tcecyk, sorry for the late reply.

tcecyk, I don’t know if there were any logs of the problem and I’ve wipe and attempted to install other roms since I last tried /e/ os though your suggestion is something I think I might need to try with the ROMs I’ve had trouble with.

Gianna, I’m not sure what you count as “stock” but the one I have did come with what I guess is an OEM modded Android 11 ROM installed. Woud /e/OS ‘Q’ be compatible if the phone was formated/wipped first or if an Android 10 AOSP GSI ROM was installed first?

Thanks to both of you

@Starhawk, “stock” Android is the common term for ‘stock ROM’ and means for your smartphone: Ulefone Power Armor 13 original firmware Android 11.

Ok, so that would explain the issues I was having.

Going back to the question in my last post, would it be possible to install/flash /e/OS ‘Q’ onto the phone if it was formated/wipped first or if an Android 10 GSI ROM was installed first?

I just tried it and it didn’t work

1 Like