Help. I can't install my device

I can’t find “OEM Unlock” in the developper options. Why? Help.

My phone is Samsung Galaxy GT-N7105.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

If you don’t tell us which phone model you have it may be impossible to help you (a Fairphone 2 for example simply has no OEM Unlock option as it is unlocked by default).

1 Like

Please try this if applicable
Fix Missing OEM Unlock Toggle on Samsung Galaxy Devices (Guide) -

The allow OEM unlock feature wasn’t existing when this device was released
Jump to next step : unlock the bootloader.

I tried to follow the instructions, but without success. Let me explain what happened.

First, when I connect the phone to the computer, it is connected as a media device and does not ask for permission to debug USB.
Second, the ADB command does not work on the phone.
After executing the heimdall print-pit command, the phone reboots but is not initialized.
After running the command heimdall flash --RECOVERY twrp-3.3.1-0-*.img --no-reboot, I rebooted, but twrp was not installed.

Translated with (free version)

Thank you. I tried it. But it didn’t work.

So, the bootloader is now unlocked


reboot the Samsung device in download mode,

reexecute the commande

$ heimdall flash --RECOVERY twrp-3.3.1-0.img --no-reboot

Then this time, be well concentrate with your fingers on the buttons,
change their position immediately when the screen becomes black,
release when you see the little blue text line on top of the screen.

What should I do? I don’t know why.

Ok ,
You flash TWRP, but you have to Immediately boot on it to etablish the installation,
if you don’t Immediately boot on it, it will be overwritten by the normal boot of android gogol system.

1 Like

Yay I have /e/ on my phone!!! Thank you very much!!!

Happy for you,

Welcome to /e/Land !