Help installing /e/ on Galaxy S9

I’m new to /e/ and was looking forward to install /e/ on my new S9 however the post of graz made me hesitate to do so. The response from archie confused me a bit since graz was talking about an S9 while the response mentions an S7.
Now if I understand correctly the problem is that if your device runs a recent stock Android version it comes with a bootloader version that is incompatible with the latest /e/ version, or partition changes are made as Manoj states. Is this true for both the S7 and the S9?
My S9 has a firmware version from 2019-11 and I think this contains bootloader version 7. I assume that I’m not able to install /e/ or end up in a bootloop. Is that correct?
I do wonder though would Updates to the Dev and Stable branches fix things?

Thanks in advance for any clarification.

1 Like

Hi @0x7C0 updates to Dev and stable branches are still on the same OS which is Oreo. If you are coming from a higher OS version it may have issues on some devices. You would have to wait for an /e/ OS official or unofficial build of the same OS level as your current stock ROM.


@0x7C0, what applies to the Galaxy S7 SM-G930F (e-0.7-nougat) does not necessarily apply to the Galaxy S9 SM-G960F (e-0.8-oreo). But I am looking for clarification.

But as @Manoj speaks from his experience, it can be »If you are coming from a higher OS version it may have issues on some devices.« Last certainty is only given when the operating system change to /e/ OS ROM was successful.

This information → here the conclusion can be drawn that /e/ OS ROM e-0.7-oreo (S9 · SM-G960F) and StockROM Android 9-pie S9 (G960FXXS7CSJ3) are much better compatible than /e/ OS ROM e-0.7-nougat (S7 · SM-G930F) and StockROM Android 8-Oreo S7 (G930FXXS7ESL9).

These are the same requirements as for @ Fab2B. Accordingly, the chances are good that a successful OS change to /e/ OS e-0.7-o- dev (oreo) can be accomplished.

My exact baseband-version is G960FXXU7CSJ5 and I think I’m gonna give it a shot this weekend. Thanks for the effort!

Successfully installed /e/ so can confirm it works for baseband version: G960FXXU7CSJ5. :slight_smile:

1 Like

In the meantime I also changed two devices (S7 and S7 Edge) with different OS versions of StockROM Oreo 8.0.0 to /e/ OS e-0.7-nougat. Problems probably only occur from device to device. Compare again "it can be" … Now I have learned it myself, that it works but also doesn’t work.

Hi @0x7C0 Im glad to hear that you installed /e/ succesfully!
Did you use the installation guide in the wiki or some other way?
If I undesrtood correctly, you have an s9, G960F, bootloader version 7. What android version was installed before flashing?


Hi @graz. I’ve mainly followed the instructions on the wiki. Except for the order of executing the ‘patch the device section’. That’s what brought me to this forum in the first place since I didn’t completely understand that based on previously flash experiences :slight_smile:
I’ve also had to sideload the vendors. There was only one strange thing and that was after sideloading the /e/ zip and wanted to restart the phone (latest step in the instruction) I got a warning that there was no OS installed. Restarted anyway and apparently there was an OS since /e/ started up. All in all in was quite a smooth experience.
The previous Android version was 9. Stock and up to date (to 2019-11).

1 Like

Thanks @0x7C0
Sorry, wha do you mean with sideloading vendors?

It’s the part from the instruction that doesn’t seem to be needed on every device so I first tried it without. But then indeed the installation did fail so I had to execute that as well. (Although I’m not really sure what it does exactly)

On some devices, installation can fail if vendors are not up-to-date. In this case, please:

    Download those vendors
    Install them
        On the device, go into Advanced > ADB Sideload, then swipe to begin sideload
        From the computer, please run adb sideload <vendors file>

Lovely, thank you very much @0x7C0 for sharing your experience! Its very helpful!

@graz, please also see this issue. Already forgot about that :smile:

1 Like

Ok, so I’m stucked in step 1… Cant install Heimdall in Mac. Is there any way to skip this and somehow use Odin or some other tool that doesnt require command lines? In Nexus 5 i was able to install adb and fastboot and then trough TWRP flash /e/ image, but this time I didnt even reach that phase

To install TWRP Recovery on the Samsung S9 SM-G960F you need Heimdall or Odin3 (Wind°ws). ADB commands work. Fastboot doesn’t work

Thanks, @archje. I checked the “HOWTO Install /e/ on a Samsung smartphone with Windows easily” tutorial from @Anonyme.

Did anyone tried this method with the S9 instead of the installation wiki?

This how-to is basically applicable to all Samsung devices. But it is well known that the devil is in the details.

Some Samsung devices require additional steps. Especially the Galaxy S9 (starlte), possibly in two points:

Patch de device 1. download the patch from here

On some devices, installation can fail if vendors are not up-to-date. In this case, please:

Download those vendors

As soon as TWRP has been flashed successfully, the /e/ OS ROM is installed in no time.

1 Like

Thank you very much for your help @archje ! I’ll give it a go and tell you the results!

I keep my fingers crossed that the OS change will work without incident. The S9 SM-G930F is still a great /e/ phone.

Thanks! In my case the phone is the following (second hand):
Model: Galaxy S9-G960F.
Firmware version (can’t find it), but the kernel version says 20.09.2019
Security patch: 1.09.2020 (in case it’s relevant, I don’t know).
Android 9.
Base band version: G960FXXU6CSGD

I’ll keep you updated with the progress.

Security Patch Level Sept. 2019 indicates the firmware version PDA: G960FXXS6CSH5.

1 Like