Help installing /e/ on Galaxy S9

Hello :slight_smile:
I’m trying to follow the installation instructions at for a Galaxy S9 and I kind of got stuck.

I followed everything in order until this section:

Patch de device

  1. Download the patch from here
  2. Install the patch
    1. On the device, go into Advanced > ADB Sideload , then swipe to begin sideload
    2. From the computer, please run adb sideload <patch file>

The instructions don’t say it explicitly, but I had to boot into recovery mode with Bixby + VolumeUp + Power.
I didn’t see any “Advanced” entry, but I did find “Apply update from ADB” so I assumed that was it.

Then I ran:

adb sideload

And it failed on the device saying:

E:footer is wrong
Update package verification took 0.2 s (result 1).
E:Signature verification failed
E:error: 21
Installation aborted.#1

The file was downloaded correctly (I checked the MD5 sum).
Does anyone know if this step is really necessary? Because it seems to be extra compared to LineageOS variant. And what does it do, actually? What kind of a patch is it? Also, if it is necessary, then how do I go about installing the patch?

Hello, welcome in our community :slight_smile:

Here is a different way to install /e/, but maybe new devices like the S9 require additional step I’m not aware of.
Don’t forget to unlock OEM in development settings.

What is the patch for exactly ? It’s not on installation instruction of my Samsung device.

1 Like

Thanks, Anonyme!
However I don’t dare to deviate from the instructions that are specific to my device.
The non-working patch is exactly what worries me. I don’t know what’s it for, maybe it’s something important.

Personally, I’m a large proponent of /e/ but I’m not enthusiastic about the /e/ installation instructions at all. That’s why I always do it a bit differently than described there.

When the bootloader of the Samsung Galaxy phone is unlocked … (which is an indispensable prerequisite for changing the mobile operating system) … can be installed as first TWRP Recovery, because then it is possible to flash the file with the TWRP command “Install”. TWRP is simply a great tool.

Checking with a root checker whether root access is enabled or not is routine.

1 Like

Little question : how do you unlock the bootloader of a samsung phone ? Is it the “OEM unlock” setting ?
Because I never had to bother with bootloader issue, and I don’t even think I unlocked OEM when I flashed TWRP and /e/.

I tried to install TWRP first, as you recommended.
Now I see where the “Advanced” and “ADB Sideload” were coming from.
I was able to install that patch from adb.

Next problem :frowning:
I wiped data, cache and system as required.
I attempted to sideload… and it fails immediately, it doesn’t even transfer:

$ adb sideload 
Total xfer: 0.00x

And on the device:

Any chance I can recover from here?

Yes, try to flash the correct vendor image first.
Download ARI9 here:
Just save it on your external sd card. When you are in TWRP, press “Install”, select your external sd card from storage, choose the correct .zip file and then confirm flashing.


Thanks a lot, @exyna!
I guess I had seen the link to ARI9 in the instructions, but somehow the context was different and didn’t realize it was what I needed.
Anyway, I managed to flash the /e/ image, and now I am the newest happy /e/ user! :slight_smile:

Many thanks to all of you for your help!


how do you unlock the bootloader of a samsung phone ? Is it the “OEM unlock” setting ?

I think that’s it. That’s all I did in the phone’s menu besides enabling USB debugging.
Also, there was no need to root the device.


Hello, I tried to install on my new Galaxy S9. I cannot installe TWRP nor the , I get this error: "Only official released binaries are allowed to be flashed (TWRP) "

I unlocked OEM and have USB debugging switched on. In fact, I could unlock OEM, then the phone reset and in the newly factory reset Samsung OS I do not find OEM anymore.

What can I do?



Hey Frank,

About the OEM setting, I think it’s OK that you don’t see it anymore. Probably if you would connect to Wi-Fi it would appear again, and it would be already enabled. I went through that too.

About the error, I remember it, I also got it yesterday. Unfortunately I had so many different errors that I don’t remember exactly what I did for each. :frowning:
Let’s see, what exact steps have you done?
Did heimdall print-pit work? Try running it again; then when it reboots, try holding down Volume Down + Bixby + Power before it gets a chance to boot into the original system.

Hi cosmin,
thank you for the quick reply!!
heimdall print-pit workes, and I could reboot into the download … again. What now ? :slight_smile:

OK, got it: TWRP is installed. I did it by
heimdall flash --RECOVERY twrp-3.3.1-0-starlte.img --no-reboot

!!! Thank you.

Will now follow your 3 further steps below :slight_smile:

At this point I would try to install TWRP with

heimdall flash --RECOVERY twrp-x.x.x-x-starlte.img --no-reboot

If that works, then the next step would be to reboot into recovery (maybe with adb reboot recovery) and try to do adb sideload with the following, in order:
1. then with

1 Like

OK, I installed the 3 steps as you describe, inclusive e-07-…zip
During install, data could not be formatted. during start of the system, the device told mee, that encryption does not work anymore and that a factory reset has to be done. No I am in a boot loop, but can get into TWRP.
I cannot mount data. Seems that I was too quick, I had to wipe before installing e-0.7…
Any idea what I could do?

Ok, I now followed the description:
4) … then tap Wipe.
5) Now tap Format Data and continue with the formatting process. This will remove encryption as well as delete all files stored on the internal storage.
6) Return to the previous menu and tap Advanced Wipe.
7) Select the Cache and System partitions to be wiped and then Swipe to Wipe.

Sorry, I wrote the message in a hurry and forgot about the wipe step.
Did it work in the end?

Hi guys I am unfortunately struggling to install /e/ on my s9 i installed twrp on my s9 but cant install any zip files. I fear i have made a terrible mistake. :frowning: im downlaoding files to mac high serria then transferring to the s9 via flashdrive and otg thanks a lot !

@andrew.c, I have had best experiences when all necessary files needed to flash a Custom ROM are stored on a microSD card and loaded from there.

Before you try again, check if the model of your Galaxy S9 is one of the devices supported by /e/ OS Samsung Galaxy S9 - " starlte" : SM-G960 F / F/DS / N (Exynos).

These S9 models are not compatible:

SM-G960 0/DS (Snapdragon) Dual-sim
SM-G960 U (Snapdragon) USA
SM-G960 W (Snapdragon) Canada

thanks I will give it a go

Sorry, I did not look here since my post above.
After correctly installing e3, and wiping of data, my phone works very well. I do use f-droid and installed Aurora Store, because the Apps Store does not work for me.

Very much thank you all, this is a very nice ROM.