Help me! I locked bootloader after installing /e/ Os on my GS290

I locked bootloader after installing /e/ Os. on my GS290. Now the phone is like dead anche i can’t unlock the bootloader again. I tried to restore android stock firmware with flashtool but i need a signed image (md1img-berified.img)

Someone can help me?

Is my phone denitly dead?

Thank you

1 Like

Hi and welcome :grinning:

What tool did you use to lock the bootloader? Did you use the phone since locking the bootloader?

thank you aidb

I used flashtool with lubuntu. No i can’t use my phone after i’ve locked the bootloader

So what you did was completely reasonable, Edit, but this is our recommended install method.


I would be very wary of reflashing as there is no “factory” image. There is an image, linked in our docs, but l suggest you delay that approach.

The error (seems) my guess, to me to be in your flashtool and its relationship with Lubuntu. I am not at a PC to double check this but in Debian I required a very recent kernel, which I did not try very hard to acquire.

Perhaps you could link your source for flashtool? On reflection, let’s avoid that.

Edit. Do you have access to Bootloader?

Reading the link above, are you able to complete all the prerequisites? Please don’t rush!

Then perhaps the fastboot unlock method will work.

No i don’t have access to bootloader. When i try to unlock bootloader thought fastboot my pc can’t identify the phone.

I tried to unlock bootloader with windows, linux, mac thought platform tools without any chance to unlock my bootloader again

I tried to restore stock rom with windows and linux and i have the same error

Just to be clear, leaving aside the PC, can you physically reach the bootloader with Volume up + Power? (from phone powered off.)

no, my screen is total black when i press volume up + power

What I think has happened is beyond my experience and I cannot find it documented here for a GS290. I think it quite possible that the lock has happened “on the wrong slot”. You could consider searching for fastboot oem unlock + Slots or Partitions. I would be very careful to try only to collect evidence of what is wrong.

I would seriously avoid spamming the phone with different unlock techniques.

When you search this forum for GS290 you may recognise some recurring issues.

Edit, back to your OP, there is a link on the Install page (which I linked above) to this:

Download Android 10 firmware

I have the same problem. I locked bootloader after successful /e/ OS installation using Easy Installer, because it is required by banking apps. No fastboot, no bootloader, only preloader and SP Flash Tool. But SP Flash Tool returns an error on downloading md1img.img from this ROM - STATUS_SEC_INSUFFICIENT_BUFFER. You can see screenshot of the same situation from other Gigaset thread - GS290 - is there a way to get back to factory Android?

I’ve tried a bunch of versions of SP Flash Tool - without success.

Looks like only official verified firmware will save our devices. Is there any chance that the /e/ OS developers will contact with Gigaset developers for verified images and help us?

This guide has a link to the GS290 stock ROM. Were you able to download and try with that.

I just wrote about it:

SP Flash Tool returns an error on downloading md1img.img - STATUS_SEC_INSUFFICIENT_BUFFER.

Hi @saintech, any news? I was just researching this subject.
Were you using the method linked above?.

If yes, were you following the instructions there exactly with regard to this detail?

Go to Download tab (choose “Download Only) and select scatter file “MT6763_Android_scatter.txt” inside the extracted firmware

I read elsewhere that it is important not to have top line [.]preloader ticked.

Are you able to comment?

Hi. Unfortunately, nothing. :slightly_frowning_face:

Of course. I wrote about this in the two comments above.

There is no problem with the preloader img here. Problem with some other images, as I remember, there are about five of them. Of course I tried skipping them, but this doesn’t help.

I am sorry but that does not seem like an exact fit with the exact wording I quoted above. Can you tell me what I am missing?

Sorry, I’m not a native speaker and may speak a little unclear. On the screenshot exactly what you wrote in the quote, and almost what is written in the flash instruction (except OS, but I don’t think it affects the error). I tried different combinations of the checkboxes from the image list, including downloading without preloader image or all except those causing the error and many others. But it didn’t help. Looks like affected images those causing the error are critical for the fastboot loading.

It all looks like the error is caused by the phone hardware, that checks the lock/unlock bootloader flag, that can be changed only in non bricked device (as far as I know). So, looks like we need help from the developers.

1 Like

Thank you for your reply! :slightly_smiling_face:

In general I think random changes of the checkboxes should be avoided.

There is one /e/user @wilminator who has reported success with this method.

Gigaset GS290 users would certainly benefit from some knowledgeable input.

.

Ubuntu is used.
Kindly change the commands and package names, if any for your distribution

in a Terminal app, execute the following commands to install the flashing-tools :

$ sudo apt update
$ sudo apt upgrade
$ sudo apt install android-tools-adb
$ sudo apt install android-tools-fastboot

Unlock the Bootloader : https://doc.e.foundation/pages/enable-usb-debugging
install /e/OS on the Gigaset : https://doc.e.foundation/devices/GS290/install
revert to stock-android.10 : https://doc.e.foundation/pages/install_e_GS290_linux
revert to stock-android.10 : https://doc.e.foundation/pages/revert_e_GS290_windows
documentation SP Flash Tool : https://spflashtool.com/
workaround to use SP Flash Tool on Ubuntu : https://www.linuxuprising.com/2018/05/fix-libpng12-0-missing-in-ubuntu-1804.html
HowTo use SP FLASH TOOL : https://androidmtk.com/flash-stock-rom-using-smart-phone-flash-tool

I was able to recover my GS290 through SPFlashtool and the ubuntu image for Volla Phone

1 - Download the image for ubuntu you find here

https://volla.tech/filedump/ubuntu-touch-yggdrasil-ota15-flashtool.zip

The volla bootscreen will appear and after a while (it may take a few minutes it will enter fastboot mode)

2 - Flashing the ubuntu image per volla phone with SPFlashtool

3 - At this point the bootloader is still locked but can be unlocked with

fastboot flashing unlock

at this point flashing the android stockrom for GS290

Your phone should restart normally (and you can lock the bootloader again :smiley:)

I hope this could be
Details that I don’t know how important they are (but I communicate them anyway):

My phone’s battery was completely dead
I used ubuntu 21.04

I hope it can be useful for someone

2 Likes