Help needed installing ROM on Pixel 2 XL

@anon64684597 so I am not the only one. Good to know. I am wondering how is this community builds getting tested? Is there something we don’t know?

@Manoj @rhunault @barczakmark I have tested latest and it is still the same. Not possible to boot, bad flash.


We are sorry for problem you are facing of. Could you please raised an issue here?

I did that long time ago, that is the first place I posted this issue here.

Did anyone manage to this working? I’m faced with the same issue. TWRP flashes the ZIP just fine, but says there’s no OS installed and a reboot just goes back to the bootloader.

@Manoj @rhunault this issue is still there. To bad, I was really looking forward to this ROM. I end up flashing COSP ROM with NanoDroid. More or less same thing :wink:

I am having similar issues with /e/ on my Pixel 2. I tried to install /e/, got the boot logo for about 10 minutes, and the phone rebooted into recovery. I reinstalled the e 0.7 .zip file and again got the /e/ boot logo for about 15 minutes. The device rebooted and gave me a prompt with a LineageOS logo stating “Can’t load Android system” and “your data may be corrupt” and asking me to factory data reset the device.

I reset the device from the prompt. The phone then rebooted, gave the /e/ logo for about two minutes, and rebooted again into the LineageOS recovery screen I previously mentioned.

Are you by any chance downgrading your phone - or was it on Pie OS earlier. We have seen such bootloop issues on most devices when we try to downgrade the OS.

I was on the Android 10 beta, but installed the current stock Android Pie ROM before trying to install /e/.

I followed the steps listed in this XDA post, just replacing the LineageOS ROM with the /e/ ROM I built.

Edit: As an experiment, I tried installing the LineageOS ROM in the XDA post I linked above and it successfully booted. It seems like there is some issue in the /e/ ROM specifically.

This is still the same problem I have posted on April 19. On Pixel 2 XL is just not possible to flash e ROM. Each of these post is actually the very same problem. Any Pie ROM for a base will not change anything, ROM will just not boot at all. I have tried all combinations and the best I can get is boot animation and then restart to recovery.

Please can you share the url of the LOS ROM you mention you flashed which worked. Will pass on the details to the build team. Maybe the sources we are using to build may have an issue.

I successfully installed and booted the August 2019 ROM listed in this XDA thread on my Pixel 2 (walleye). Here is the direct link to download the ROM.

Thanks @wilson for sharing the links
@rhunault we may need to look at the device tree for the Pixel builds.

For those of you who are interested, I was able to successfully install and am now running /e/ on my Pixel 2 thanks to the work done by @Phie on the GSI images.

Here is the link to the thread on the /e/ community with more info from @Phie.

If you are installing on the Pixel 2 or Pixel 2 XL you’ll also need the vbmeta partition image listed in this XDA post.

1 Like

Hi @wilson, any chance you could post the steps you went through and links you used to get /e/ installed on your Pixel 2? It would be much appreciated! I’m anxioius to try it out!

If you are coming from a stock Android 9 ROM, look at my previous post in this thread. You should be able to follow the steps in the XDA post and use the GSI provided by @Phie. If you need help troubleshooting, it’s probably better to start another thread.

1 Like

This has been a long thread. Anyone with a Pixel 2 XL on which the official or unofficial /e/OS build works.

Hi do you have by any chance a full tutorial on how to install on walleye?