HELP NEEDED ! TWRP password prompt after january 2022 update

I have updated my Samsung S9+, bought from the store, with the december 2021 without any issue, however after the reboot of the January 2022 update, TRWP comes up with a password prompt.

It is the first time I see this since I have bought my phone.
Usually the update is self generated and never asked me for this type of technical manipulation.

What should I do?

Note : also, I work in IT, I really don’t know anything at all about mobile, so if you have a simple step by step procedure, I would be delighted.

As I can’t use my phone any more, I am desperate for support.

Thank you in advance
Best regards


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I cannot reproduce as i don’t own the device, but there are tons of stories on this forum for years, use the search bar… Search results for 'Password twrp' - /e/ community
As well as i understand, try using your phone PIN code, if exist, or simply letting empty,
Please Tell us the results

Of course we do not know why it happened to you today. If you are aware of no passwords which should be involved, one of the workarounds is to just press cancel when asked for the TWRP password.



First thank you @piero and @aibd for your replies.

This is what I tried already :

  • Pressing cancel → see below
  • Type my phone lockscreen number (not SIM card PIN) → wrong password

I am offered with a variety of options which I know nothing about.

I went through the options and already try reboot but I always come back to that TWRP screen.
The menu looks like the screen shots in that post : [HOWTO] install /e/ on a Samsung device from a GNU/Linux PC successfully

What should I do?
Wipe? :frowning:

Honestly I am very afraid to do the wrong stuff and get my phone unusable. :sob:

Thank you in advance
Best regards


In twrp, have you tried to hit -->reboot -->system ?


With the install feature, navigate to /data/lineageos_updates/ and try to install manually the newest downloaded “”

1 Like


This worked : when prompting for TWRP password, press :
Cancel > Swip to allow modification > reboot > system

Thank you @piero it worked! :pray:

This did the trick.
It did show that the January update failed but that’s ok.

If I get prompted for a TWRP password after each reboot, I’ll follow the other post.
In the meant, I know what to do if this happens.

Have a nice weekend