Help needed (Unofficial build for kccat6)

Hi - please move the topic to wherever it belongs, maybe it’s not correct here.

I’m bit stuck with kccat6 (Samsung S5 LTE+/SM-G901F) unofficial build. While the build itself runs without a problem, the ROM isn’t working at all when using encrypted storage (didn’t try it without). It’s only booting until the storage is to be unlocked and gaing into reboot seconds after that.

A selfmade lineage-16 doesn’t suffer from that problem at the same device (buildsys taken from GitHub - ionphractal/docker-androidbuild: A modern Docker image for building LineageOS in Continuous Integration and Continous Deployment.).

Does any kind person have helpful hints on how to debug and fix that problem?

Thanks in advance

Do you need to build custom Pie ? Or unofficial test R ?

When Official /e/ image ROM download is Pie for kccat6

Hello piero, thanks for the response.

Downloaded ROM exposes the same problem - that’s the reason I tried to compile it myself (and wanted to change some included apps). So for me Oreo would be sufficient - but I tried v0.19.2-pie. Maybe there’s something better?

Last month, i installed
without problems…

As it is written in the official site,
twrp-3.2.3-0-kccat6.img don’t support encryption.


  • v3.0.2-0 - See here for the changes.
  • v3.0.1-0 - See here for changes!


  • MTP support
  • USB Mass Storage support
  • Micro SDcard and USB OTG storage support
  • f2fs file system support (read, write, format, backup & restore)
  • exFAT file system support (read, write, format, backup & restore)
  • NTFS file system support (read, write, format)
  • Backup & restore of modem/baseband/firmware (not bootloader!)
  • ADB root
  • Full SELinux support
  • Built in android 6.0 tree


  • Samsung encryption is not supported


If you really need encryption, Better try to download or build unofficial TWRP 3.5.x-x

1 Like

thanks – I’ll give e-0.17 a try.

So you’re telling me that broken encryption is twrp’s matter, not e’s (I’m on twrp-3.2.3-0 too)? How does lineage-microg work around then, as it’s fine (selfade, as written above, but most of the apps taken from /e/ are crashing, so I suspect some framework difference)?

Will give that a try (check other TWRP versions and /e/. Would be nice to have it running :wink:

Ah, finally got it (TWRP, Samsung encryption)… so there must be a difference between Samsung encryption and the one of Lineage. I remember having had trouble short after switching on encryption, but somehow I got out of the reboot loop and managed to install both TWRP and Lineage again. At some tme later I retried encrypting the device and it simply worked.

Just tried all /e/ from 0.17 downto 0.15, and none of them worked with encryption. So my only chance seems to be staying on Lineage until I find some help with debugging the issue.

After having tried all versions starting from 0.15 to 0.19 again with encrypted device without any success I had success with that (all from (unofficial) own builds):

  • unpacked the e-0.19-p-*,
  • replaced boot.img with the one from a well functioning lineage-microg build (same android version, same day, so the source base should also be the same),
  • re-packed zip.

Success :slight_smile:

1 Like

Can you share your package?

Which one, the (non-functioning) e build, the lineage-microg (in case you’d like to fiddle with that) or the one from above? Is there a good place to drop that?

Can put it somewhere tomorrow, have a much better bandwidth at work ;D maybe I can find a public accessable place…

It could be nextcloud with private or public share first then someone with account put it on

1 Like

I sometimes use with their free service offering.

Have a look at e-0.19-p-20211107-hacked-kccat6 and e-0.19-p-20211107-hacked-kccat6.

If it’s of any value, we should maybe move it to a more persistent location, as mediafire will scrub it after 2 weeks.

1 Like

There are two versions of the free account, registered and unregistered. Account deletion will happen after eight month not logged in and two email notifications for a registered free account. Unregisted, as you said, after two weeks and naturally without notification.

I will put it on my share after the two weeks if necessary.

There was a little hint on top of the page that they “may” shred that - not htat they WILL. But worst case is maybe that they do. :wink:

I digged deeper and found it…

I already took boot.img apart and noticed only 2 differences: one in sepolicy and one default.prop IIRC. Latter one was only some prosa, but didn’t manage to find some good explanation and tool for sepolicy. Replacing that one didn’t change behaviour beside that I had the impression that time until reboot happened was longer, but this in turn could be misleading (didn’t measure). So could you please share your knowledge?

Sorry, can’t help you here. The phone is still in use until christmas with the last official LOS version