Here we go again... Upgrading XA2 to T, on top of existing S

Well, it’s that time again… With no OTA upgrade from S to T possible, it is time to re-flash the ROM yet again, now that updates to S have stopped for the XA2. I had hoped that it might be possible by now for upgrade process to be OTA but, sadly, it seems not.

Anyone else in the same boat? I’ll have to look back over my cheat notes from the last few years all over again… I might just try sideloading the new recovery and ROM and see how it goes. Anyone done it yet?

I’m out of the loop with /e/ but I just did a dry run, for fun. You can use the existing 1.19 recovery on device and sideload the update without wiping. Back up just to be safe.

So the steps would be:

Download the new rom and open terminal in same folder (check the hash if you wish)

Set usb debugging and make sure you get the toast confirmation on the device screen where you tick the checkbox. Running adb devices can make this happen.

Run adb reboot recovery to get the recovery up

Then adb sideload to get the ball rolling.

The screen changes when it’s finished installing (you know all this, I’m sure), press the arrow at top left to go back to recovery home screen and select reboot system.

Don’t expect much visible difference. You’ll want to check the version in settings just to believe it!

I’m out of the loop, too – I now run a Google Pixel with GrapheneOS, but I still have my XA2 for a backup, including possibly for travel. The thing I miss most on the Pixel is Advanced Privacy, especially the fake location.

Anyway, here goes…

And, done. Painlessly. Thanks @chrisrg

Now I do your trick and wait for the next version to auto-update and we’re back in business!

Of course, this thread is mainly for people who come afterwards and need to see what was done. In the past, earlier threads have proven useful to others, so this is intended primarily as a knowledge base.


Thanks for sharing! I have been in the same update situation several times and did some testing by myself to get things working.
Sometimes it is working seemlessly smooth without any circumstances but I also had situations where i struggled to get things working over weeks.
Did you have to recover your phone from a backup after the update?
In my case I was at the same state as before the upgrade when flashing “over” the old system. Even though it is recommended to make the extra step and go over the StockRom when base Android is changing. Currently I am facing some issues with the T version which could relate to the “dirty flash”. Would be interesting to know if the same misbehavior occurs on your phone.
See Feedback for v1.20 - #227 by PopeElizabeth for further information an that.

In addition I was not able to find a StockRom for my device, so I tried it without the detour. Could be the same in your case.

Since there is no Sony XA2 stock ROM for A13(T), I just sideloaded over the top of the existing e1.19-s. Usually I just erase the phone and do a clean install/upgrade, without bothering to do a backup, since I like to start afresh, but this time I just sideloaded, so there was no wipe. It’s not my daily driver anymore, so it was not a huge risk, and nothing was lost, so this was the most painless upgrade so far.

I also sideloaded e1.20-t onto my Samsung Galaxy Tab S6. Same deal. No wipe, nothing lost.

On the 11 (R) to 12 (S) upgrade it probably would have been recommended to update the firmware by return to stock ROM. I did seem to find Stock ROM Android 12 (S) on this link (no idea how reliable) (But it worked ok for you.)

However the Android 13 (T) builds contain firmware parts which are expected to upgrade the firmware so “Return to stock ROM” + “Format data” are no longer a part of the process for Upgrade to T (from correctly installed S). Further it seems that Moto did not upgrade the device beyond Android 12 (S).

Format data may be significant if the data partition still contains “markers” for Android 11 (R) if it were the case that no Format data happened at the previous (11 → 12) upgrade.

This topic was automatically closed after 32 days. New replies are no longer allowed.