Hidden ip adress not working with auroa/app lounge

Trying to download a geo restricted app in aurora and app lounge. When hiding my real ip and logging in with google account it does not work.

I cleared both apps’ data, tried again, no difference.

Especially Aurora does not show among the apps with internet permission in advanced privacy, even though it clearly is online.

App lounge doesn’t change its results either.

Any ideas?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hiding IP = using Tor. A number of sites or services don’t like doing business over Tor. You can try a few things.

  1. Set exit node to the country you live in and see if that works. Manage my Internet address → My Internet activity must appear from: (choose from drop-down list).
  2. Exclude Aurora Store and App Lounge (uncheck).
  3. Do not use Hide IP feature.