How exactly can I install e/OS on my Fairphone 5?

Dear community,

I have installed e/OS before with great pleasure on my Fairphone 3 thanks to the easy installer. But now I’m struggling to install e/OS on my Fairphone 5. It’s probably because I’m a noob at these things. Because I simply don’t understand the instructions given online.

I saw a post that the easy installer was available for Fairphone 5

But when I downloaded the easy installer, it did not support the Fairphone 5. Also when I check the supported devices list, I don’t see ‘easy installer’ listed next to FP5.

I then tried to understand the manual install instructions. But there are just some basic steps I already do not understand. For example step 1 of installing e/OS: “unzip the archive”.
Which archive? From where?

I then tried to find a version of the easy installer that does support FP5. And I think I have found it via this page:

So I got excited: ‘Yay, maybe I can still install e/OS easily!’
But now my problem is how to get the newer version of the Easy Installer running on mac (intel).

Because the readme file says:

“1/ Build the easy installer application normally” (sorry, but what is ‘build the application’, and how do I do that?)

“3/ Run the ./mac_package.sh script. This create a folder EasyInstaller-installer containing the EasyInstaller.app (application)” (run the script where? I tried Terminal, but that did not work).

So it seems that I’m already getting stuck with the simplest steps that apparently are so simple for developers that they don’t bother to explain anymore. Is maybe anyone still willing and able to help me get e/OS installed? (A)

here is the Official method

.

there is an alternative method that need to be writed

  • using a custom recovery
    TWRP or the recovery-e included into the /e/.zip

  • and an recovery compatible file

1 Like

Thanks! But the official method was the first I really did not understand, mainly the ‘unzip the archive’ part. It also appears that the official method is for Windows and Linux, but not Mac?

it is the same method for Linux and mac (both are based on Unix)

This is referring to the Downloaded ROM.

From install page, https://images.ecloud.global/dev/FP5/, the section

Downloads for FP5

you can download either Official / stable ROM or Community dev ROM. The ROM you download is a .zip file. Your PC is likely to have a tool to extract or unzip a .zip file or archive.

Although for a different Fairphone (3) maybe reading this will make some of the terms more clear. [HOW-TO] Flash /e/-OS on Fairphone 3 using Debian based GNU/Linux.

  • (You dug into history and found an unfortunate link regarding Easy Installer, let’s not go there … but FP5 was introduced for Easy Installer but it was withdrawn. So you were correct initially when you decided Easy Installer is not an option for FP5 right now.)
1 Like

Ah thanks! That explains…

Okay one more basic question I don’t really understand. Maybe you know how to solve this.

I found this link that says where you can download SDK Platform Tools for Mac:
https://doc.e.foundation/pages/install-adb

But when I download and unpack that folder, I get just that: a folder. I can’t open it as an app. So how do I go from downloading SDK Platform Tools for Mac to an opened program where I can type my commands?

I am not a Mac user but I just downloaded your version and unpacked it. It seems similar contents to Linux. I just changed directory into platform-tools and there I see the familiar “executables” adb and fastboot

Mac platform-tools demo
:~/Downloads/Mac$ ls
platform-tools  platform-tools-latest-darwin.zip

:~/Downloads/Mac$ cd platform-tools/
:~/Downloads/Mac/platform-tools$ ls

:~/Downloads/Mac/platform-tools$ ls -l
total 27712
-rwxr-xr-x 1 iain iain 13594560 Mar 20 15:41 adb			<<--
-rwxr-xr-x 1 iain iain   671344 Mar 20 15:41 etc1tool
-rwxr-xr-x 1 iain iain  4066400 Mar 20 15:41 fastboot		<<--
-rwxr-xr-x 1 iain iain   134624 Mar 20 15:41 hprof-conv
drwxr-xr-x 2 iain iain     4096 Mar 20 15:41 lib64
-rwxr-xr-x 1 iain iain   562256 Mar 20 15:41 make_f2fs
-rwxr-xr-x 1 iain iain   562272 Mar 20 15:41 make_f2fs_casefold
-rwxr-xr-x 1 iain iain  1566768 Mar 20 15:41 mke2fs
-rw-r--r-- 1 iain iain     1157 Dec 31  2007 mke2fs.conf
-rw-r--r-- 1 iain iain  1107565 Dec 31  2007 NOTICE.txt
-rw-r--r-- 1 iain iain       38 Dec 31  2007 source.properties
-rwxr-xr-x 1 iain iain  6084496 Mar 20 15:41 sqlite3

~/Downloads/Mac/platform-tools$ ./adb --version

I guess there may be other details to get right (I think I saw a Mac user say that you cannot execute stuff from the Downloads folder, or eqivalent), I found this in a quick search https://stackoverflow.com/questions/31374085/installing-adb-on-macos

The first command to use is

adb devices

This will do nothing to the device other than to get it to identify itself with a response like

123abcdefg345 device
2 Likes

i have just booted a MAC i have, to test the ADB install,
but both Firefox and Safary are outdated, and i just cannot download the file, sorry.

only thing to do with that MacBook 1,1, actually running MacOS 10.6.8 “snow leopard” is to install linux on it.

1 Like

Wel… today I gave installing e/OS another try… and my Fairphone 5 got bricked.

The whole process was quite frustrating really. FP5 was constantly not recognized as a device, so entering commands like ‘adb reboot bootloader’ in Terminal failed, and we constantly had to restart developer mode. When it finally did, it turned out the installer was only suitable for Windows.

We then succeeded in installing e/OS via Windows. But we encountered the problem that Gitbash did not recognize the command fastboot flashing lock_critical.

When we tried to lock the bootloader via Mac & terminal, and we clicked ‘lock the bootloader’ the phone got bricked…