How remove microG of /e/ os?

Hi all,

Thanks to your developement of /e/ os.

I just want to remove microG of my device.

Is it possible ?

Thanks a lot.

1 Like

One Question: What’s the reason for removing microG ??

MicroG is here to allow apps which normally are requiring Google Service to run on /e/, why do you want to remove it ?

Because i want to remove all google services of my devices to avoid sending google information

Yes, it is possible.

“Pure” LineageOS 16.0 (without GApps, without mircoG) runs … for testing purposes.

Banking apps don’t work, but messengers like Signal, Threema and Wire work fine.
Also GoogleMaps(!) and some other apps more.

For purists who also call and SMS with their smartphone a “Pure” LOS16 can be sufficient. So why not try /e/ OS without mircoG?

By the way: The microG packages can be removed via ADB command. How this affects the overall behavior of the /e/ system - I can’t say at this time.

1 Like

microG is a open source replacement of google play services. All connections which microG will do to google server are done anonymous.
As archie has written, some apps won’t work without microG. If you think you can go without microG, remove GmsCore from /system/priv-app/ folder via twrp file manager or build your own e version without microG.

I have everything disabled in microG and so far all the apps worked that I tested. Signal, Riot, Telegram, Maps, etc. Only thing I noticed is that Wire does not send notifications but I know that it should work. At least it does for some users without microG.

yes, some apps do need play service or microG for push messages/notifications. I know it from protomail.

So you can go this way:

  1. start twrp
  2. mount /system
  3. open twrp filemanger
  4. open /system
    there you will find the folder ‘priv-app’. In that folders you will find the folder (GmsCore). Now you can MOVE the apk from inside the folder it to an folder insite of your /sdcard.
  5. reboot

if everything working you can delete the apk after all testing. If something don’t work, move the apk back the GmsCore folder


Well, I’ve tried this way.

The device started as usual.

In the menu “Settings” the entry “MicroG >” is still available - and offers two options to choose from:

⟳ Open app again
▴ Mute until device restarts

Both options lead to the /e/ start screen.

So, now > 6. power off

Now I test with Android Debug Bridge (ADB) …

$ pm list packages|grep -i microg



… and I still get 3x org.microg packages.

What is the meaning of these 3 packages for my experiment » /e/ OS without microG? «

this is an error message, because GmsCore is missing. You will get it every time you try to start microG in settings

The first and the second are for location services. Without you get no location on maps or weather apps
the third is a safty feature.

you can look on microG site for more information

@harvey186, My experiment is » /e/ OS without microG «

To do that, I’d have to uninstall those three packages right now, right?

If you really want no location services, than yes

@harvey186, elsewhere here in the forum I just read that microG cannot be updated manually, only via /e/ OS Update.

My theory is: If I download microG directly from → Servies Core apk file (→ and rename this file to GmsCore.apk and replace this “old” GmsCore.apk with the “new” GmsCore.apk in /e/ phone (→ /system/priv-app/GmsCore/GmsCore.apk).

Is the /e/ OS system then also “updated” with this procedure or are important components missing?

I’m nit sure that it will work, because GmsCore is not all ‘microG’. So if you will only change the GmsCore.apk it could be hat it will get trouble with other components.
But you can try. If you have moved the apk and your system get’s instabile or won’t boot, move the apk back or make a dirty flash and everything should work again.

I think it’s better to use the latest update of eOS. It has the latest microG version on board

I like learning by doing. That’s why I usually try out my therapies from equipment. Today I first chose the way of asking questions - to try it out in practice.

I was encouraged by the sentence “The GsfProxy version does not need to match the GmsCore.apk version and is installable without higher privileges.”

First I renamed the file GmsCore.apk with the TWRP file manager to prevent overwriting. Then I followed installation instructions Julien Schmidt on github com / microg.

Well, no sooner said than done. The test system starts as usual. If it works properly, we will see.

By the way: It’s certainly safer for the majority of users if an update is done by the official /e/ OS support.

Hi Archie! How did you manage it?
I tried those same steps but microg doesn’t get recognized by the system anymore. If I clock on it in settings it crashes, and the app can’t be found as a installed app.
What I did was downloading the new version from the website, renaming it and moving it into the /priv-app/GmsCore.apk and chmod 644 (in TWRP). What am I missing?

Archje has leave /e/OS and the forum

What are the others parts ?

i found those informations :

  • microG packages (binaries sourced from here and here)
    • GmsCore: the main component of microG, a FOSS reimplementation of the Google Play Services (requires GsfProxy and FakeStore for full functionality)
    • GsfProxy: a GmsCore proxy for legacy GCM compatibility
    • FakeStore: an empty package that mocks the existence of the Google Play Store
    • legacy microG’s mapsv1 reimplementation

I hope it’s help

Yess, that’s it. I think all must removed/repaced

Hi I have to agree, I was search for the same solution and found your post, I thought the whole point of /e/ was to avoid Google and it’s “services”, . I was surprised to see a complaint after I downloaded Nordvpn apk via the browser, and the error message appeared which said to “Enable Google Play Services”. I use signal, Threema and F-droid and have no need for a service that blocks the operation of my vpn.