How to disable spam folder?

Hi there,
I am subscribed to a lot of news, podcasts, feeds, you name it, and a lot of them keep going into the spam, I tried marking them as not spam, but into the spam they go regardless,

So, how can I disable the spam folder?, like, I want all mail to go to the inbox folder, I tried creating a filter to move from spam to inbox, but I guess it could not be that easy.



Mails should be classified by Rspamd just after SMTP reception, so a user filter/rule may worth a try as it should run at a later time.
I recommend to move messages to a new dedicated folder, not Inbox.
Also, please be aware that messages will still be tagged as SPAM, so your email client may also take actions …

You will probably need to do the “not spam” marking in your email service, not the email client. Log in using webmail, mark everything that has been problematic - you may need to temporarily label some things as “spam,” just so you can then revert them to “not spam” - then log out, and hopefully the client will respect the main service’s settings.

Yes, I meant I have been trying to do this on the webmail all along, and still keeps going into spam, I have tried to make filters on the webmail as well, it does not work either.

I have tried ‘settings> folders> system folders> select system folders> spam> do not use’, and that does not work either.

I have been setting mail to ‘not junk’ every time, on the webmail, it does not work,

I have explored the webmail settings troughout, unless I am running a different version of the webmail, I can not find a reazon fot it not to work.

So, I do not know what else to do, sorry if it reads like venting, this is not my language.

Is there an official /reddit for Murena?, I have not tried that, xD


Not that I know of. Support is available here, and in the a dedicated Telegram channel:

Would you please share all the X-Spamd & X-Rspamd fields from one of the “spam” messages ?
You can get them from “Show source” here (menu all the way to the right) :

1 Like

With /e/ or Murena email system, moving back a spam message to Inbox (manually, or marking it as “not spam”) will train the Bayesian/neural system. This will work at IMAP level, so with both Rainloop (web) or email clients.
But this will have effect on server behavior only after many moves (default is 30 is I remember well), and Bayesian/neural has to be the cause for the “spam” classification …

1 Like

I’ve never found it to be responsive in Thunderbird, but maybe I just haven’t marked items as “not spam” often enough.

It is important to check Spam fields within the message source, as they give the classification symbols.
If the Bayesian/neural are not the main cause (check values), it is unlikely that training will work :frowning:

For example:

With my personal configuration of Rspamd (I don’t know about :wink: ):

=> this email had a score of 12.41/13, triggered “rewrite subject” action: added “** SPAM **” in beginning of subject, and message was moved to SPAM folder because of the X-Spam-Status: Yes, score=12.41 in headers.

But! If Bayesian was OK after training (-3 is the maximum value), it would still get a 9.41/13 score at best, header would be added, and message may also be moved to SPAM. Because of the other values in red.

Note: some classifications can be changed by sender (owner of domain and/or server), for example URIBL* (has to ask to be declassified), MIME* (has to write a better code), etc.
So, if it’s legit, you can also send the headers to the sender as information, it can help.


Ok, I created a filter to move all incoming messages to spam, seems to be working,

So spam is now the default inbox, whatever, I really do not care which folder is the acting inbox as long as I do not need to be guessing where are my messages.


1 Like

Has a legitimate solution to this been found? I receive emails from an address and about 50% of them go to spam and the others don’t. I’ve added the sender’s address to my contacts on the murena email client and I click “not spam” every time I receive a new email, but they still continue to get filtered. Very frustrating.

Not by me, the best ‘solution’ for me is stated above, it no longer has to determine if it is span or not, everything is spam, period. xD

I … feel your pain little grasshoper xD, try setting the same filter, everything will go to spam, you will no longer be hunting down your messages, and the frustration will cease, once it becomes predictable, since it is ALL in the same folder.

It does not have to be the all-to-the-spam-folder thou, it can be a new folder just for that, but ,I mean, I did not even bother creating a folder, the system seems to LOVE spam, so I gave it to it, XD.


Thanks for your reply. I did see your method, but unfortunately I find having a spam folder helpful. Fingers crossed this gets sorted.

I would say that Post #9 would be the way to go. Especially you could target one sender and see what it is about the incoming mail that is creating the disturbance.

Could it be possible to actually have the capability to just disable the spam folder and have all mail arriving in the Inbox - if that is possible, I have not yet found the way to do it.

Otherwise, if the filtering responsible for sending some messages to the Spam folder is part of the SnappyMail webmail app (is it?), a useful workaround could be to have the capability of disabling SnappyMail entirely for your personal account.

The presence of the Spam folder and its regular false positives is causing me headaches. I have to monitor some 15 mail accounts, which I do via imap - Thunderbird on the desktop and K9-Mail on mobile devices. While on the move without a laptop/desktop (which is a good part of my time), I use the K9Mail “Unified Inbox”, which draws all the messages present in the Inbox folders of all the mail accounts. So I miss whatever gets redirected to the Spam or any other folder. To not miss any, I would need, for each of the 15 email accounts, in turn: to select the account, select the spam folder and refresh it to see if there is a message in there. Not really an option. :frowning_face:

Disabling the Spam folder (or SnappyMail) would seem to be the only viable option.

With K9 you can choose which folders are included in the Unified inbox. From the hamburger menu on top left, for the selected account you can see a list of folders, a separating line and the item ‘Manage folders’. Select that, and click on the Spam folder, which displays the settings for that folder, Tick the ‘Unify’ checkbox, and emails in the Spam folder should now appear in the unified inbox. The repeat for the other 14 accounts :wink:

Great. Many many thanks @petefoth :slightly_smiling_face:

I had failed to find that possibility in K9.

I have ticked the ‘Unify’ checkbox for the Spam folder, and also had to change ‘Folder poll class’ from None to 1st class (otherwise, refreshing the Unified inox did not poll and refresh the Spam folder).

All working smoothly. Great piece of software that K9. I think I will increase my annual contribution to it.

Not sure it is a good thing that Murena does not allow people to disable their Spam folder though. :confused:

1 Like

Using Thunderbird, you can change “All unread” (in “Local Folders”) search folder properties, to include your Spam folders.