How to disable Tasks-app notifications?

I use my own app for Calendar and Tasks, so do not want to use the native /e/-apps.

I see that it is not possible to disable these apps, that is grayed out in Settings > Apps.

Still, on /e/ Nougat 0.13 this was possible: for both apps I revoked all permissions, and set them to give no notifications, that works fine.

On /e/ Q the options are different: it is not possible to disable notifications anymore.
For the Calendar app, this seems not a problem: one can still revoke all permissions, and this seems enough to silence Calendar.

For tasks, I have also revoked ALL permissions. But still, if new tasks arrive (for my tasks app CalenGoo) the native Tasks app is going to show their notifications.

That means that every night, after 00:00 hour, the lock-screen is bright white from the many task-notifications, all incorrect.

Any suggestion to disable Task-notifications on /e/Q very welcome!

By the way, this is a deal-breaker for me. There are several reasons why the NextCloud and /e/OS Calendar and Tasks do not work for me.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

By the way, I thought maybe I found a solution, but it turns out that even disabling the relevant Task-lists doesn’t stop Tasks from showing notifications. (Taksk >> … >> Displayed lists >> disable.)

Aahhh! Now maybe I found a workaround.

In Tasks >> … >> Displayed Lists >> (at the bottom) Synchronized lists >> disable all unwanted lists.

Now, it seems, that no notifications appear! While my own Calendar/Task app (CalenGoo) still works good.

(I didn’t notice that option at first, seems to me an inconsistent lay-out of the settings.)

Last point: indeed, the above works, this way new tasks (made with one’s own task-app) will not be synced, so do not give notifications. But existing future tasks will still give notifications (although the task-list is not shown!).

The solution for this is to

  1. disconnect the phone from WiFi and mobile data so it cannot sync
  2. in the native Task-app >> … >> Displayed Lists >> (at the bottom) Synchronized lists >> set the task-lists to sync and be shown again
  3. remove all tasks (or at least the ones in the future)
  4. set the task list to not sync again.