How to disable the "recent apps" button?

Hello !

  1. About my phone : I use a Samsung Galaxy S6 Edge (Zeroltexx) with the system version 0.7-2020021541379

  2. The trouble : The “recent apps” button is activated randomly without me touching it, leading to two possible situations :

  • displaying recent apps
  • opening two apps in split screen

This already used to happen when the phone wasn’t running /e/. (Android stock firmware is what I think it is called ?) This is apparently a known issue of the Samsung Galaxy S6 Edge.
Also, a clean /e/ install does not fix it, nor running the phone in safe mode.

  1. What I tried to do : Disabling the “recent apps” button by first
  • rooting my phone (SuperSU)
  • installing Total Commander file manager, granting it root access
  • Going into File system root / system / usr / keylayout / Generic.kl
  • Opening Generic.kl as a text file and editing it in the following way : adding a # before key 580 APP_SWITCH, and finally saving the file, which I was told would disable it. This did not work, the button keeps self-activating.

I also tried using button remapping apps, but none of them fixed the problem.

  1. What I need your help for : Could someone suggest a way to disable this “recent apps” button for good or even better, fix it so it does not self-activate ?

Many thanks ! :smile:


you can go in Settings > System > Buttons > Recents button and select “No action” for the short and the long press.

1 Like

Or in the same category, enable navigation barre instead of bouton

For root rights, flash magisk.apk by using TWRP

1 Like

Hello, thank you for your contribution. :blush: I tried to find the navigation bar option using the search function in settings, and it yields results such as navigation bar, Enable on screen nav bar, but when I click on them, it brings me to the Buttons menu, where no navigation bar option is to be found.

Try /settings /boutons /boutons and disposition
(second line for me)

My tablet is under nougat, but don’t have physical boutons,
My phone have physical boutons, but it is under pie and do not have the same settings menu

1 Like

Hello and thanks for your answer.

What you recommend is actually the very first thing I tried, but it sadly did not stop the recent apps button from self activating, and surprisingly, it still works and shows me recent apps when I tap on it even though I set no action for both short and long presses.

Thanks, I will give it a try.

Bonne journée :smile:

Hello @Bryophytae,
I’ve already tried various firmware for the Samsung Galaxy S6 Edge “zeroltexx” (from custom roms 7-nougart, 8-Oreo, 9-pie and LOS 17.1, but I haven’t noticed this problem yet.

Do you have any screenshots to help me with this?

PS: Have you ever tried the unofficial e-0.7-oero build from /e/ user Unknown akanonymous to see if this phenomenon occurs here?

1 Like

Hello @archje

I think a video rather than screenshots would show the problem better. The first 15 seconds of this video is what happened to my phone.

I found a solution : setting the recent button to no action in both my personal and work profiles. (Which I didn’t know was a possibility). @Anonyme was right, and couldn’t know I had a work profile, and I apologize for not mentioning it, I didn’t think it would be relevant.

My phone is now acting normal, and somehow the recent button still works even though I set it to no action. This is fine, all I wanted was my phone to stop having seizures.

I will definitely try the unofficial build you mentioned, sounds great :smiley:

I would like to apologize : the solution was indeed quite simple, but I seeked your help because I had tried many things before and was getting desperate.

Many thanks to all of you who so kindly helped me, I’m very grateful !


1 Like

I’m glad you found a solution for yourself.

And yes, my S6 Edge does not run smoothly with /e/ OS n(ougat) either. At least a migration to /e/ OS Oreo 8.1.0 would be desirable. Even better would be a /e/ OS 9-Pie Build.

I console myself with very well working LOS 17.1 builds as a compromise solution.

1 Like

@archje your mention of LOS 17.1 piqued my curiosity. How does LOS 17.1 compare to /e/ in terms of

  • privacy
  • security
  • stability ?

Thanks !

Hej @Bryophytae

Stability. Relatively good at the current “beta” stage of development. Of course there is still a lot to do.

Privacy & Security. /e/ OS starts where LineageOS ends. LOS 17.1 is just an alternative for me, which cannot replace /e/ OS under these aspects.

1 Like