How to edit system files on e os and fp3?

In order to make the banking app Vipps work on my e os FP3+ i came over this explanation for its installation on lieage os. I have tried the method, but can not make ADB edit system files.
I have opened ADB in command prompt on win 10 and can access the phone, but using the command mount --remount -o rw / i get the return ‘/dev/root’ is read-only. i can edit the file with VIM, but it cant write to the system.

Does anyone know how it can be done?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Did you enable Rooted debugging (that’s not Android debugging, it’s an extra setting) and start with adb root, like your link says?

1 Like

adb shell should give you a # when using root mode, not a $.

I can confirm the method is working on my Xiaomi testing device (Pie) :

Llinked blog post from your link seems much more complicated, but it is also a much more proper way to achieve the desired result.

1 Like

Thanks for the reply! Yes, I can confirm that both Rooted debugging is enabled and that i started with adb root. And the shell opens as FP3:/ #

In this case this may be specific to FP3 :frowning:

Better wait for a FP3 specialist advice …

Yes. Tanks anyway! At least I know it is supposed to work…

Not sure if this has to do with the FP3 being an A/B device or an Android 9 vs. Android 10 thing.
But searching the web I found

And I’ve just tried

adb root
adb remount
adb shell

Then, when executing mount on the phone I get

/dev/root on / type ext4 (rw,seclabel,relatime)

Seems to be working this way.


When I try to execute adb remount i get:

C:\ADB_platform-tools\platform-tools>adb remount
E Skipping /vendor
E failed to remount partition dev:/dev/block/bootdevice/by-name/system_a mnt:/: Permission denied
/system/bin/remount exited with status 10
remount failed

Would that help?

My wild guess would be you forgot the adb root? Or maybe it was in root mode already and a second adb root removed it again (I honestly don’t know)?