How to enable/disable a sim card?

Hello.

Is there a way to enable/disable a sim card with a phone with dual sim feature?

I’m using the fairphone 2 with two sim cards, one sim as private number and the other as business number. The FP OS does have this feature, but it seems missing at /e/os or I won’t find it.

Thanks in advance for help.

@rhunault @PaulaFairphone Please can you offer any suggestions to @vic.fontaine he is using a fairphone

I only have one SIM, so I can’t test dual SIM, but with just one SIM inserted I can confirm that there is no option to disable that SIM. On FPOOS and Lineage OS 15.1 it’s available.

So completely switching off one SIM doesn’t seem to be an option in /e/ yet. If you just want to switch which SIM to use for fast internet connection you have to set the preferred network type for the other SIM to 2G.

1 Like

As PaulaFairphone said, it is an option available on LOS 15.1, so on /e/ 0.2 (see screenshot bellow from Xiaomi Mi A1). So this option will be available when /e/ 0.2 will be available for Fairphone 2.

2 Likes

Thanks guys for your quick reply!

@rhunault: When will /e/ 0.2 be available for FP2?

As always with software development there can not be any time guaranteed and the devs said in November:

Also, for now, supporting formerly supported (Nougat) devices on Oreo is not a priority project.

Alright, I’ll wait patiently.

As @Markus said, no date for the moment.

Hi. The feature is at Android Pie for FP2 now available but deactivating a SIM slot takes no effect. Calls get still through.

That sounds very strange and is not true in my case (i.e. after deactivating one of my SIMs this phone # is no longer reachable).

Indeed! Yours is also a FP2?
I just tried again: Outgoing and incoming calls get through even the respective SIM is disabled.

Yes, it is.
How can you select the sim on an outgoing call? It doesn’t ask me to select one any more when one sim is disabled.
Also incoming calls are not possible then as sim is not booked in into mobile network. Does one sim triangle disappear on your phone when you disable a sim?

EDIT: Just tried again for outgoing calls and you’re right. It seems possible to use both sims although one is “disabled”. I’ll have to try with incoming calls again and let you know then.

Any idea if this issue is there in the stock ROM or LOS builds for FP2

I’ve done some thorough research and I suppose there can’t be done a lot in /e/ by now:
Disabling a SIM in current LineageOS version for FP2 is the same (and it has already been mentioned long time ago e.g. here). It also seems to work fine on first glimpse. But as in /e/ pie version the SIM is not really disabled. So incoming and outgoing calls are still possible.
Root cause of it is probably, that in current stock OS the SIMs can’t be disabled at all. Disabling them is only possible in a December based stock OS beta version (and there disabling a SIM works perfectly).
EDIT: I’ve also checked in LOS17 Beta1 for FP2. There’s again no setting at all to disable a SIM.