How to find FP3 pie images and how to get magisk to use them?

Dear community,

I tried to ask for help in the troubleshoot forum, but no reaction so far. So I’m asking here in the hope that somebody knowledgeable sees this.

I bought my FP3 about a year ago, installed /e/ and rooted with magisk, and quickly proceeded to make this my daily driver. I installed a bunch of updates using the OTA updater app, which promptly threw out the Magisk changes, but as I only ever needed app root for backup and restore, it took me a while to notice.

Currently, my phone is still stuck on Android 9, using build /e/OS 0.16.20210425112188. (A bunch of other FP3s I bought via came with Android 10 preinstalled, so I want to unify.) I want to fix Magisk for this version, so I can take a complete backup of all apps with Titanium et al. and then upgrade to Q.

When I have the OTA updater give me a copy of and extract the boot.img inside it, Magisk 0.22 and 0.23 both always fail to patch this file with

- Copying image to cache
! Process error
! Installation failed

(I tried to fastboot boot a current TWRP for FP3 to try cleaning the cache, but that only resulted in a hung boot.)

So I guess my questions currently are:

  1. Does the OTA updater possily give me a broken boot.img inside the large zip? If so, where can I download the pristine version? ( only links to directories that list the Q build.)
  2. If that file should be OK, how can I convince Magisk to patch the boot.img so I can boot into a rooted-for-apps system?

Thank you in advance for your help in getting this sorted out. :slight_smile:

– toganifed

I installed /e/OS and Magisk this way:

  1. Install /e/OS
  2. Install TWRP as described (“Fix Recovery Bootloop” was not necessary, it threw an error but the phone works correct)
  3. Flash Magisk ZIP from TWRP (no boot.img patch needed)

For OTA updates I follow this tutorial (but Step 1 is not necessary with /e/OS because it does not check for unchanged boot.img but simply overwrites it). So I just begin with step 2.
I did it this way with several OTA updates and everything works correct.