[HOW-TO] Flash /e/-OS on Fairphone 3 using Debian based GNU/Linux

Hi /e/ team,
as you may know, the FP3 had a recent oopsie that has the potential to destroy my data.
While most of my stuff is backed up, I did the traditional “i’ll set up a back up for that stuff later” on some other important stuff, and I’m just wondering how I would go about flashing the old rom onto my FP3 whilst keeping my data partition intact. I’ve heard of the a/b fix but according to this, that might not go too well.
From what I understand, there’s a total of 6 partitions that the FP3 houses.

fastboot flash system system.img
fastboot flash boot boot.img
fastboot flash vendor vendor.img
fastboot flash dtbo dtbo.img
fastboot flash product product.img
fastboot flash vbmeta vbmeta.img

Which one of these houses my data, and what do I not flash to keep my data? Do I have the wrong picture of android partitions in my head?

The A/B “Fix” doesn’t do anything with any partition or with user data, it just changes the OS slot to boot.


The case you linked to needs clarification on what exactly the user did.

There are several more.

The data partition which has your data is called userdata, and because it has your data an update doesn’t flash or wipe it. The wiping of it is part of the instructions of an initial manual install, though.

Great! Thanks for the directions. I’ll try the fix now.

Step 3.
fastboot devices
no permissions (user in plugdev group; are your udev rules wrong?); see [http://developer.android.com/tools/device.html] fastboot

I allowed USB debugging for this computer before shutting off and starting fastboot mode.
From the website provided in the message I tried the instructions but with no luck.

This did nothing:

sudo usermod -aG plugdev $LOGNAME

What next?

This didn’t help:

sudo apt-get install android-sdk-platform-tools-common

IIRC you have to log out and back in after the “usermod” command for it to take effect (if you haven’t done so already).

yep, relogin or newgrp plugdev to change your group to it interactively. But then new files in the terminal session will be created with that group too.

No, it was not as easy! :wink: (Because of fastboot-udev-rules).

But thank you very much for your really good description, now it works on my FP3+ with the now Android 10 beta.

1 Like

There is no


anymore in newer versions like https://images.ecloud.global/dev/FP3/IMG-e-0.12-q-2020111084008-dev-FP3.zip right? No consequences if I just skip

fastboot flash product product.img

Or would there be some?

https://doc.e.foundation/devices/FP3/install doesn’t list fastboot flash product product.img anymore.

1 Like

In the /e/documentation (https://doc.e.foundation/devices/FP3/install) the last step is the lock of the bootloader.
Is it mandatory or may I leave the bootloader open? In a later case of unlocking, all data will be erased - I would like to avoid erasing…

It isn’t mandatory to lock it, but be aware that it is advised to lock it for reasons.
Make sure to set up a screen lock if you leave the bootloader unlocked.

To leave it open just in case you don’t need to unlock it later for reasons you don’t know yet … I don’t know … I would rather run the risk of having to set up the phone again.
(But then again I choose to not have banking Apps on my phone, oh, the bliss :slight_smile: .)


Not sure, where to ask this. Maybe this is a good place.

Now that /e/ finally allows for Corona Warn App to work, I would like to revert back. However, I am currently running LOS 16.0 and I am not sure if the official install instructions will work under those circumstances, especially since I would be upgrading to from pie to Q. Has anyone tried it? Does anyone know if complications are to be expected?

Thanks in advance!

Hello everyone!

I hope this is the right place to post my question, as it concerns different threads.

Wanting to degoogle my mobile life and having read about the e-foundation I bought a used Fairphone 3 (Android 10 installed) last week. And now I am trying to install eOS. However, I am completely new to the field…

In a first step I tried to follow the instructions on Install /e/ on a Fairphone FP3/3+ - “FP3”. In order to do so, I downloaded the necessary files and installed “Minimal ADB and Fastboot” on my PC (Windows 10). However, I got stuck with the command: “fastboot flash recovery twrp-3.4.0-0-FP3.img”. I got: “FAILED (remote: partition table doesn’t exist)”.

I then started reading across different forums. In different places, I found the recommandation not to install TWRP on the FP3 as this would make OTA updates impossible in the future. (E.g. here.)

When I came along this thread here, I realized that in this instruction no TWRP is flashed to the FP3. I am therefore wondering whether I might adapt this instruction for me (although I am not using Linux but a Windows 10), and install eOS in this way?

Any recommendations on that? Could it be a feasible way at all? And if so, are there certain commands which would have to be adapted?

Thanks a lot in advance!

After replying I saw you essentially asked the same thing in a separate topic so I moved my answer there to avoid duplicates. I think it’s best to continue there.

A huge THANK YOU for this how-to, it is EXCELLENT. The only hick was the ‘product.img’ which is still in the howto but not in the downloaded zip any more. But I found AnotherElk’s post further down in this tag. Maybe you could put a notice on top of your howto telling noobs like me just to get on without being frightened of missing something.


I can t edit it anymore for now, that would be for @Manoj to enable :slight_smile:

Hi @Chimpthepimp I have made it a wiki…Pl go ahead and make the edits.


It was very important issue to preface all commands with sudo to get it to work, but finally it works great!

1 Like

Thanks for your Guide! :+1:
I’ have one question though. I’ve followed all your steps and managed to use /e/ successfully on my FP3.
Is it Okay now to disable in the developer option the “OEM unlock”? Or must it be enabled?


I just bought a new FP3 and would like to use it from the beginning on with /e/ -OS (currently Android). This tutorial has worked great so far, but now I can’t get any further. When I enter the commands to install /e/ -OS in the terminal an error message appears (see screenshot in attachment).

I don’t have Linux or GNU, but a MacBook Pro (macOS Mojave 10.14.6), but until now everything worked as described.

Maybe someone has an idea how to solve the problem.

Thanks for the help.
Bildschirmfoto 2021-07-05 um 14.19.58