Fairphone 3 : Update

@Manoj If I want to update my FP3 (purchased in the e shop) it stops the download at 99% and I have to start it manually again. When it finishes the download it says verification failed. What’s the problem there, do I have to register my phone somewhere so it could update the stable Versions?

You should have /e/os 0.11 from the stable channel.

Edit: i think so.

Hi @fp3 since your issue is regarding a FP3 you purchased from the eStore pl send in a mail with the details to support@e.email The team should be able to guide you further.

Installing OTA e-0.12-p-2020100376806 kicks me to recovery “Can’t load android system…” - Factory reset would be the worst case (several banking apps would cause paper mail requests for activation keys…). What went wrong? What can I do to avoid factory reset?


FP3 is an a/b device that means it has 2 partitions to boot. Since the install seems to have failed, you could try to boot the other partition (the software before you installed the update):

First you have to find out what partition you are on now:
fastboot getvar current-slot , its either a or b.

If it was a:
fastboot --set-active=b

if it was b:
fastboot --set-active=a

Then reboot, it should now boot the version before installing.


Same for me with Update of October 3.
fastboot --set-active=b did not work out, device rebooted with a factory reset. So all data lost. How can this happen? Really angry about this! In 10 years of custom roms, this never ever happened to me!

Are you sure this was a factor reset? Maybe the b partition just didn’t have any of your data and its still all on the a partition?
Curious about this too because I’m trying to recover as well!

There is an issue with the last FP3 build which went OTA. The build is being removed from the OTA servers

This is kinda bad, @Manoj Some users might prefer stable channel… is it allowed to post link to stable ROM here?

Are you asking for the stable channel build url ?

The phone did a factory reset without any prompt or user interaction?
(I know the phone can boot into such a prompt when something went wrong, but you would still have to actively choose to go ahead with a factory reset.)

No, I already have it :smiley: it is not rocket science to find it… is it allowed to share here so people can choose dev or stable?

Been hit by the nasty update bug. Did the fastboot --set-active=b and was allowed to use the phone again. Thx for the tip. Hth,

1 Like

Need help:
fastboot --set-active=b didn`t work -> fastboot: unrecognized option ‘–set-active=a’

Can I flash the img over even with locked device state?

Yes, power off your phone and do this

Have you booted into fastboot mode?

If you copied and pasted the “” (one dash, looking rather broad) in this directly from your command line/terminal … the command needs “--” (two normal dashes).

Else … make sure you use the current Android SDK platform tools.

Was using ubuntu terminal - Copied the “- -” inside this forum.
Will give windows a try…

There was some trouble with somehow obscure fastboot command versions in some Linux distributions a while ago.
The current tools I linked to should take care of this.

Can you try typing it out instead of copying? If you copied “- -” then that would be a ‘-’, followed by a space, follewed by “-set-active=a”, which would be incorrect.

Ok guys installed it in windows and worked - uff - handy up and running
Thanks a lot for your help

Didn´t know why not working under linux/ubuntu - fastboot version 1.6.0 was installed - I also tried to update fastboot?