How to link contacts to QKSMS

Just starting to show my partner how to use QKSMS I find that there is a problem in linking the number of a received sms to the name of the sender which exists in the Contacts list. I can’t find a way to link the two apps. A quick search on Internet shows that this is a problem encountered by users in the past who have complained to the developer and he said, as of last year, that he was going to fix it. Apparently the problem is related to the fact that the contact list stores the number in international format with an initial “+” sign and when QKSMS receives it as a local number (with the initial zero) it is unable to link it to the corresponding contact. Does anyone know if there is a fix for this? Or have I missed something in the parameters of the app?

that’s one of the reasons why I was against QKSMS. With silence this works oz of the box.

(Sorry, that’s no help for you )

I am not sure about the contact list storing numbers in the + format having something to do with this issue part. I have save my contacts in the Contact Apps in all formats - some with +, others with 0xx (ISD code) and then the number, others simply the 9 digit mobile number and I can see the contacts in my QKSMS.

Perhaps a solution? Playing around with the Permissions of QKSMS I deactivated the access to Contacts then reactivated all permissions, also to Storage. Then restarted the device. Now suddenly the contact’s name appears. I perhaps should just have reactivated all except Storage and restarted to test if the reactivation to Contacts alone was the problem. I don’t know if access to storage is a potential risk, but I should imagine QKSMS would need this for its archive function. I’ll get another friend to send an SMS just to make sure that his name shows up and that the link with Contacts app is permanent.

An article about Silence and Signal would be helpful. As a newbie I don’t really see much difference, both can accept and send normal “unsecured” SMS too.

To answer @pjmbraet about Signal, I only know this app having used it on a non /e/ phone as it is the only app that I’ve persuaded my family to use. It works as well as Telegram for most purposes, creating Groups of users, transferring files, etc. At first it had a few problems with Video calls, and it relies on the user verifying the security code as happened once or twice when a correspondent hadn’t used it for some time. But it’s an easy process. It also works perfectly managing ordinary SMS and so can be used with contacts who haven’t got Signal on their phone, but it obviously marks it as an “insecure” connection. According to an article comparing it with Telegram the encryption security is always used between two Signal users, even for voice or video calls, which is not always the case with Telegram. It also doesn’t allow anyone to take screenshots, quite how I’ve no idea, but the article praises its authors for making it fully open-source, which allows anyone with the know-how to test its security features. From what I’ve read about Silence, it uses the same API as Signal (probably a fork of it I imagine) but uses the normal SMS functions of your phone, which means that a hacker could see who you’re calling but not the content of your call as it is encrypted.

So Signal is better.

You can allow Signal to take screenshots in Settings > Apps > Signal > Permissions.

1 Like

Yes @pjmbraet you’re quite right. You can allow yourself to take screenshots of messages you receive, as I’ve just discovered. After a bit of further research I found that the reason for this is to prevent other apps on your device from capturing the image; as I read on reddit:
it is to prevent the task manager (and other apps?) on your own device from caching screenshots.
Apparently there is an Android function designed specifically for this purpose and it is used in banking apps. So with Signal it is up to the user to activate this function, as you had noticed.

1 Like

Hello @Grendel,
I had the same issue. I had imported my contacts yesterday, some with phone numbers in international format, some in local. In the message app, I checked the settings, and tried out “synchronize messages with the Android native database”. Problem solved :smile: (but from what I read here, the cause and solution might not always be the same).
Kind regards,