How to remove SMS warning?

I only send a text very occasionally, but always get a warning about too many texts being sent, sometimes the text doesn’t go, as I have looked away and not seen the warning to ignore it. How do I stop this warning appearing?


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi @Confused,

would you have a screenshot of the warning?
So I guess it is a warning in Message app. Are you trying to send a message to more than one person or only to one person?
What is your version of /e/ and what is your device?

On my side, I never saw a warning except when the message is not sent (network issue, …)


Photo of warning attached. Only sending occasional texts via messenger to one person at a time.

Samsung S9 + e/OS 1.8

How many receivers did you select?

You may check “SMS message limit” in Settings/Privacy/Trust.


That setting allows for 30 messages in 1 minute by default which is quite generous.
Since the OP said occasional sends and doing more than 30 in a minute to one person doesn’t seem likely, there may be something else in play.
[ Although “one person at a time” could mean more than 30 “one persons” but still hard to do in one minute I’d think ]
Maybe some rogue app with SMS permission sending things in the background or ???.

A quick search shows this issue has been an annoyance for at least a decade. An issue was posted in the /e/ GitLab last year but no action due to invalid bug report template.
I’ve never experienced the message, even when I used to do a lot of texting with coworkers.

Could be achieved by delayed sending of queued messages. Assume there’s no network connection when the Send button is pushed. And again and again. And then suddenly the connection comes back. All these messages go then out in a few seconds. Not sure if that is possible without other error messages. (OK, but who sends more than 30 messages without that they go out?)

Could also be achieved by an automatic background process (I mean another app or malware).

1 Like

@Confused you better check the real current settings in your phone. I had the same issue (same warning for each single sms) after an OS update a while ago and found the setting say “always confirm” whereas I never had issues like that before the update nor changed those settings myself before.

Thank you. This fixed the issue on my FP3+.

Hi @Confused,

seems that other guys have been quite faster than me to give you an answer.
But as @obacht seems to say, perhaps a bug if you never touch this setting…

I sent to just one person.

Thank you everyone for your help. Much appreciated. It was in Phone settings Trust (see picture). I had looked in the message app settings before posting my query, never thought of looking in that area of phone settings before.