How to restore device after wiping internal storage

Hey Guys

I tried yesterday to encrypt my device (galaxy J500FN) and I got the impression my device was stuck in some loop, because every couple of minutes my device was rebooting and I had to enter my PIN-code, and this was going on all afternoon. So after having been busy for hours (seriously) I was getting tired of it and I decided to see what I could do to change the pattern, whenever I got into TWRP after rebooting again. I was fully aware that had the risk of resetting to factory settings, but I had made a backup before entering the process, so it didn’t seem to be a big deal to me.

However, I am starting to believe a made a big mistake at that time, because now my device is entering TWRP whenever I boot the device. So I thought I could solve the issue by copying the e-image into internal-storage and then go through the installation-process again, but it seems my internal storage is wiped entirely. When I plug in my device by usb into desktop or laptop I can’t find my internal storage, and also in TWRP it says my internal storage is 0 Bit.

So it seems I seriously screwed up.

I have to admit I don’t entirely know what I am doing, but…

*could somebody please roughly outline the steps I have to go through to bring my device back to life (assuming this is still possible, because I like to stay positive)?

thank you in advance

Go to TWRP / Wipe menu.
format data (left side bottom) EDIT: I mean ‘RIGHT’ side :wink:
Reboot to TWRP
push to your device
flash with twrp install menu
and hope, everything will work again

EDIT: by the way. This: ‘When I plug in my device by usb into desktop or laptop I can’t find my internal storage, and also in TWRP it says my internal storage is 0 Bit.’ is, because your /data is enrypted. And that’s why the new e-install fails. With format data as described above it should work,


Hi, hi, hi, I’m having déjà vu [left site - right site].
A little bit of fun is necessary. And you understand him, don’t you @harvey186 … No offence!

Ups, sorry was standing in front of a mirror :joy:

I have the same device and know how to make the encryption work on Samsung devices when it doesn’t work.

  1. Have you tried Wipe > Advanced wipe > Select dalvik, cache, data, internal storage, system > And swipe to wipe ? Does it work or is there some red errors ?

  2. When you start the encryption process I guess your phone will directly show the “e” bootlogo and ask for the PIN code, and your phone won’t be encrypted. Is that correct ?

really ??? I think that’s no good Idea !!! Wipe / format data, yes, aber not ‘internal storage’

Could be that ny inforamtions are old, but I have learned: ‘never wipe internal storage’

I’ve always wiped Internal Storage. Since we don’t want to keep any personal data I don’t see why it’s bad.