How to root eOS without TWRP?


I’m the new owner of a Xiaomi Redmi Note 8T. I can’t use TWRP for installing eOS, because TWRP breaks it, badly. I’ve installed eOS 1.8.1 with the e-Recovery, and that works fine.

Now I want to root my device. How can this be done without TWRP? There’s some documentation on how to install Magisk without TWRP, by tweaking the Zip of the OS, which is to be installed. That looks awfully complicated. Are there any other options?


You have to use fastboot to flash the “magisk-patched-recovery.img”

Which version of TWRP are you using?

Not every TWP version is equally suitable for every Android version!

I recommend not to use the current TWRP version 3.7.0 but an earlier version.

You can also install TWRP only temporarily and try to install with it.

1 Like


I’ve tried at least two TWRP versions (3.7.0 and 3.6.2), and eOS 1.7 and 1.8.1.

Anyone, don’t install TWRP temporarily. It breaks eOS to just install it. I’ve tried it, with eOS 1.8.1 being the installed version. I’ve went into recovery in order to see if it still asks for a password. I haven’t done anything. But that was enough to cause a weird problem again. It’s the settings app crashing immediately after starting it. I’ve had the same problem before, when using TWRP to flash eOS (1.8.1 and 1.7).

Bye, Volker

The subsequent installation of TWRP on an existing /e/OS ‘R’ or ‘S’ + eRecovery is often problem loaded. That’s why I wrote “Try it”. It failed for me as well.

However, a new installation from scratch with /e/OS e-1.8.1-r-20230206257804-dev-ginkgo willow + TWRP + magisK worked on the first try.

The fact that the BlissLaucher app shuts down with the message “BlissLauncher keeps stopping” and the screen flickers is not unique to the Note 8T, but has already happened to me on several other devices with /e/OS.

All in all, a rooted /e/OS is not necessary for me.

I thought temporarily using TWRP meant fastboot booting its img. Would allow for flashing or other task without it ever being installed. Not sure nowadays.

Not aware of any Magisk zip tweaking. Just a Magisk.apk copied to and flash / sideload.
Usually works but no longer recommended.

Installation | Magisk