How To Transfer Files Using USB Cable? (SOLVED)

I have a Sony Experia Z5 that I’m trying to transfer photo files from to my laptop using PCLinuxOS. When I connect my phone to the laptop using the USB cable, the phone appears but when I click on it I can’t access any of the photos stored on my phone. I do not yet have a SanDisk card installed in my phone, could that be the problem?

Search for ‘USB Prefernces’ in settings of ypur phone. There you must set ‘use USB for File transfer’

Than you PC should see your internal Storage of yourphone

On some phones a little windows will open where you have to allow the connection

Under the settings window of my phone there is no ‘use USB for File transfer’ option. Thanks for trying to help. I installed the KDE Connect app on my phone and on my laptop but it didn’t work either.

I think I may use a portable wireless modem as a hotspot so I can use my laptop on the go instead of using my phone. A laptop keyboard and touchpad is much faster than a tiny keyboard on a touchscreen.

The setting mentioned above by harvey186 is under the “Developer options” section. If you forgot how to unlock this hidden section:

  1. Open Settings, and select “About”.
  2. Tap on “Build number” seven times.
  3. Go back, and select “Developer options”.

And you seem to have misunderstood my recommendation of KDE Connect from another topic. This tool is not for wired file transfer. This tool is meant to get the most out of your phone’s integration with your PC.

I can’t buy decent batteries for my flip phones anymore so I had no choice but to purchase a smart phone. I was opposed to the idea until my computer geek friend informed me about /e/ as an alternative to living with Google’s continuous data mining. He walked me through the installation of /e/ on my phone so I remember tapping on something 7 times during the process.

I have no experience integrating a phone with my PC. Using a smart phone for email seems like a waste of time since I can type and communicate much faster on a laptop keyboard than pecking out a message one character at a time on a touch screen that’s barely large enough to avoid hitting the wrong character.

Thanks for taking the time to explain harvey186’s instructions to me.

There was no ‘USB Preferences’ option under Developer options, only ‘Select USB Configuration.’ It’s currently set on MIDI. The only other available selections are: ‘Charging’, MTP (Media Transfer Protocol), PTP (Picture Transfer Protocol), RNDS (USB Ethernet) and Audio Source. Should I select RNDIS?

Isn’t MTP what you need?

I also had the following case. Recently, I tried to connect my just wiped phone to computer for the first time. All the settings were made correctly, but for some reason I could not access the folder of my device. It turned out that I simply didn’t take into account that when you connect your android to any PC at first time, a request on its verification appears in the notification center.

I tried all the settings in ‘Select USB Configuration’ to no avail. On some settings the internal phone files displayed on my laptop but the picture file was empty when I opened it. Then I finally figured out how to open the notification panel and saw ‘Android System USB charging this device Tap for more options.’ After double tapping I was able to choose from several options under ‘Use USB to.’ I selected ‘Transfer files to another device.’ Then I had to open the DCIM file to locate the photos. I was able to drag them to the photo file on my laptop. I was also able to drag and drop music files the same way. Super simple!

Well … I had the same pb.

And found the setting mentionned by @harvey186 to be located in “Connected devices” (Appareils connectés" in french) : at the bottom, you then get a “USB” entry, and when you tap on it, you can select from 3 options about “Use USB connection for” :

  1. Recharge this device
  2. Transfer files
  3. Transfer photos (PTP).

Selecting the 2nd one fixed the pb for me :slight_smile:

Hope this helps.