How to uninstall /e/ from Fairphone 3+?


the question is probably pretty simple. I sell my Fairphone 3+ on which is installed /e/ and I want to delete /e/ again and install Android. Is there a tutorial for this somewhere?

I’ve already searched the forum, youtube and the /e/ FAQ for what I want to do and I haven’t found it. Hopefully I have not just used the wrong search terms. If that should be so, it would be great if you could post the link here.

Thanks a lot

You don’t need to uninstall. You just install a different OS.

“This article will also help you to revert to Fairphone OS if you installed a different Operative System (OS)”


Avialable in

1 Like

I am doing the same thing but not sure how to unlock the bootloader of /e/OS. Any help would be appreciated. Thanks

How to unlock the bootloader is given in the /e/ install guide for the Fairphone 3/3+, section “Unlock the bootloader” … make sure OEM unlocking is enabled in Settings - System - Advanced - Developer options (this would emulate the first step) …

If not done already, you can make the Developer options visible by tapping on the Build number in Settings - About phone a few times until you are being declared a developer.


Thank you AnotherElk :pray: I’ve managed to unlock the bootloader, however, when typing “sudo chmod +x FP3_flashall_linux” and “sudo chmod +x FP3_flashall” the terminal says that there is “no such file or directory”
I extracted the package here:

I have extracted a few times in multiple places because I thought the package maybe incomplete. I also tried installed "Android ADB & Fastboot"and successfully wiped the phone but couldn’t find the stockROM file (as mentioned in "piero"s first link) in my extracted folder, so abandoned that. Last night the Bootloader screen glitched into a very dim illegible fade of text, however today the bootloader looks as it should.

I’m using Ubuntu 20.04.2 LTS and have a Fairphone 3+

Any advice will prevent me from selling this for spares and repairs

If you are sure you are operating in the folder where the files are, you might want to try adding a ./ in front of the filenames to force the terminal to get them from the current folder.
(e.g. ./FP3_flashall_linux)

Can happen. I’ve seen it do spectacular colour effects and stuff, but this shouldn’t hamper operation, unless it makes the text unreadable and you want to read it :slight_smile: .

Thanks for your reply, but when adding the sudo chmod +x ./FP3_flashall the terminal reply is still “no such file or directory”

Another thing I’ve noticed is that when I’m on the bootloader screen, the Bootloader Version and Baseband Version, have no numbers after them (not sure if that matters)

Any further advice is graciously welcomed, from a guy lost in the bootloader

Can you post a screenshot of the terminal session when you enter the command and the error message is given back?

Here are my attempts, it always comes back with “no such file or directory” except when I type in sudo chmod +x ./FP3_flashall from the terminal that opened in the folder, which doesn’t say anything…

Which means you got this one right, it worked.
You operated in the folder where the files are, and you made FP3_flashall executable, it can now be executed.

I don’t know what you are trying to achieve with FP3_flashall_linux … there is no such file in your screenshot, so the error message seems to be correct.

In your other terminal you are not operating in the folder where the files are, so the files can’t be found there, so the error messages there seem to be correct, too.

You might want to have a look whether there are any Fairphone Angels in your vicinity who might be able to help you in person …

1 Like

I am just looking for the simple things here! The chmod +x command is just going to make the target file executable.

When you issue the command correctly the terminal does as asked. Zero response from the terminal is correct: “no reported error” and you are now ready to move on to the next thing. :slight_smile:

Thanks guys! Yes, the FP3 flashall script successfully ran!

However, I now am faced with…

I’ve tried it again a few times but a bit tentative to run the factory data reset

Unlocking the bootloader should have forced a factory reset already for security reasons, so there’s no data to lose anymore.
If it makes Android happy, just let it factory reset again now, a factory reset in the Android world doesn’t touch the installed OS, it just resets the data and cache partitions :wink: .



Android wanted the factory reset and we are back in buisness

Thank you AnotherElk :pray: