How to whitelist emails for spam filter?

Hello,

Several times I tagged an email as legit in spam filter, and future emails from this source are still put every-time in the spam folder.
There are important emails where I need to be reactive, as they are in spam I do not get a notification so I miss them.

Is there a way to whitelist an email address so these emails don’t go to spam folder?
I searched in the interface, both on my phone and on the web portal, I did not find it, the only whitelist existing is for something else.

Am I missing something? Is there a way to fix this?

NB : I cannot use a filter as a workaround, as it does not allow me to move incoming messages to the Inbox, only other folders.

Thanks in advance for your help!

PS : not sure I post in the right section, do not hesitate to move this topic if relevant…

Regain your privacy! Adopt /e/OS the unGoogled mobile OS and online servicesphone

Hi,

There is no user-manageable setting. But you can still get it to better work.

First step is to open message source, and find why it has been marked as spam (X-Spam, X-Spamd, X-Rspamd).
Most interesting will be the “X-Spamd-Result”, listing the causes of tagging the message with scores (the highest is worst).

If highest score is FUZZY, repeatedly moving the message to Inbox should train the engine.
Please note that it won’t work if some others move similar messages (i.e. mailing-lists) to their Spam folder. Fuzzy storage and scoring is system-wide.

If highest score is about something else (i.e. URIBL, FORGED_SENDER, DMARC, MIME, …) there is something bad with the sending server or the message content.
Best bet here is to inform the sender, providing him the full message source (or forwarding as attachment). If it is a serious company/individual, it would be able to use this information to resolve the issue.

Please feel free to post your obfuscated X- header here.

I encounter almost the same problem, with random mails going to SPAM.
The highest score of the email I found is: BAYES_SPAM and BAYES_HAM.
The senders are various, they send a lot of emails, and I never consider them as SPAM before.

What should I do with that information?
It’s annoying, as currently those fake spams represents 10 to 20% of my receiving emails

Thanks for your help

Hi, here is the extract of the message source spam section:

I systematically approve them, but every-time it keeps going into spam.
I just would like to declare it into a whitelist to make sure it is not, it sounds like a basic feature to avoid false positives by users…
If there is any way or any workaround, please let me know…

Cheers

:warning: please note that my experience is only based on Rspamd configuration as provided here: https://github.com/mailserver2/mailserver/tree/master/rootfs/etc/rspamd/local.d and here: https://gitlab.e.foundation/e/infra/ecloud-selfhosting/-/tree/master/config/mail/rspamd.
Murena admins may have set different values/settings!

@recontact @Fly Both of your concerns seems related to statistics and neural learning. Please see https://rspamd.com/doc/configuration/statistic.html for clarification.

As far as I understand, the statistics module includes a learning process (minimum learns is set to 30 in mailserver2):

  # Minimum learn count for both spam and ham classes
  # to perform classification
  min_learns = 30;

  # Autolearning is performing as spam if a message has reject
  # action and as ham if a message has negative score
  autolearn = true;

For information, here is the status of a lightly used Rspamd, you can see learn counters:

Maybe Murena performed a Redis database reset, and statistics are to be reconstructed?
So, I suggest continuing marking messages as HAM (or moving them back to Inbox), and keep on eye on scores. There’s nothing more that can be done at user level.

@Fly I also receive emails from Doctolib in my selfhosted Murena cloud, and they come as HAM.
As far as I know the setup is quite the same in public Murena cloud. So there is a good chance that your score is only about temporal statistics.

@recontact BAYES_HAM shouldn’t flag the message as SPAM, there must be something else…

1 Like

There were some suggestions on how to create email filters here

1 Like

Hello @Manoj ,

As I mentioned in my first message, I cannot use filters to force them into Inbox as Inbox cannot be used as a destination folder in filters, it’s greyed-out.

Please provide a solution or a workaround for this issue, it’s really annoying for a lot of people.
For example in the case of Doctolib it is a medical platform, it’s legit and important to get notifications quickly.

image

@smu44 thanks for this feedback, so far it’s still going into spam, like a lot of others emails source that are perfectly legit. We should be able to force a whitelist at user level to avoid these many false positives.

Thanks & Regards

I discussed this issue with the developer. The team is working on a solution for this based on the feedback we have received. I shall share more details once we have a plan in place.

Great news, thanks for the feedback, looking forward for more details when available :slight_smile: