[HOWTO] Backup and Restore Data on Android Devices

Because I have never known installing TWRP to cause loss of data. Unlocking bootloader will cause loss of data, but that is not covered by this tutorial.

What steps did you follow to flash TWRP. What device are you using?

Files I copied from TWRP MTP mode all got the same timestamp something in 1970 - unusable for backup of only changed files - like I do with FreeFileSync with device connected via USB
I got twrp-installer-3.5.2_9-0-FP3 installed

actually the only reliable tool I’ve got is Titanium - up till now only Signal didn’t work after recovering

Interesting. I can confirm that the current TWRP 3.6.2_9-0-FP3 using MTP offers no change timestamps. I’m using Windows 11 Pro on the computer side.

And apparently this isn’t entirely new, although seemingly dependent on the device or on the computer OS … https://github.com/TeamWin/Team-Win-Recovery-Project/issues/1065

I just asked the TWRP maintainer for Fairphone 3/3+ … let’s see.

FreeFileSync got that working reliably? There were a bunch of MTP problems reported in the past.
Anyway, doing this sync with /e/OS booted is not an option (since you mentioned Titanium)? The timestamps are there when /e/OS does MTP.

1 Like

I must admit, I’m not shure if it worked with my /e/-installation.
It works with my Lineage-install. I’m using it regularly to synchronize files between my FP3 and Win10(pro)-Computer. Should work for /e/ just the same - a lineage-fork - isn’t it :wink:
actual IMG-e-1.2-r-20220727206630-dev-FP3 I tested bases on lineage 18.1
I actually use latest 18.1-package

Thanks for your answer. Stepped away from the forum for some days :slight_smile: Aehm. I do not know exactly anymore which steps I followed, but mostly internal documentation about TWRP and unlocking the bootloader. Maybe XDA too. Should have read this first “✏ FP3: unlock the bootloader - Guides - Fairphone Community Forum

I’m using the Fairphone 3.

So, used the wipe to flash Android 11. But now my build-number seems suspect to me: “eng.root (…) dev-keys” is not what I wanted. Bootloader is locked, but SafetyNet is not working anymore, CTS profile does not match.

Android 11 (R) currently is only available on the dev release channel, still marked as beta …


You can compare these download filenames most easily to Settings - About phone - Android version (tap on it) - /e/OS version (it has the same version string format).

1 Like

Thank you for digging those posts! I had no luck with my keywords :slight_smile: Seems like, I need to reflash or do you think there might be a chance, that once Android 11 is out of beta, my build-number gets “stable”?

You will need to reinstall for stable. The dev beta will just stay dev once out of beta.
Changing the release channel is always a new install.

But you can only install Android 10 (Q) currently as stable. An OTA upgrade to Android 11 (R) is just announced without a timeline, until then upgrading to Android 11 (R) would be a new install again.

1 Like

On the (rooted?) software angle, has anyone used App Manager for backups?
The new version 3.x of the app now can import backups from apps considered EOL/old/abandoned; such as oandbackup, Titanium Backup, and SwiftBackup.

On my Essential PH1 I originally had /e/OS Nougat and used TiBu and oandbackup. When I moved up to Pi/e/ I stilled used TiBu, but only for data restoration. Since Oreo, restoring of apps has resulted in problems so I install apps manually or via app stores and then restore data. While I was on Pie I would also do backups with OandBackupX (Neo Backup now) in addition to TiBu, just in case. When I moved to Q I was still able to restore data with TiBu without issue (save for those I knew data restore wouldn’t work such as Schildichat, Linphone, etc.).

AM v3.x was released after the move to Q so I haven’t had a chance to check out how well it will restore data from imported backups.
No way to test at the moment. I do still have a multibooting Oreo device where I guess I can test that but…

FYI, for non-root users, App Manager also operates via ADB over TCP and Wireless debugging so root isn’t needed. Just a bit more involved.

I already tried using App Manager for backups, about 6 months ago (it was a 2.x version).

I took the backup using TCP/IP root mode, seems quite complete.
But, when I tried to restore it on the same device after a full reset (same Android version, more recent build), the restore was not as good as expected : while some apps were fully working, some won’t launch at all, other were missing some files, etc.

I plan to build a new version for my perseus (Xiaomi MiMix3) with Android R, so if the build is successful I may attempt to use AM 3.x for a Q->R backup/restore of my apps …

Yeah, apps not working properly after restore has been an issue since about Oreo due to new security stuff. I missed being able to flash a zip of core apps (TiBu’s update.zip) when I setup a new ROM.

Now I archive apps/apks and install them manually. Then only restore the data.

By the by, the old ancient My App List (from 2014) turned out to be a great tool for quickly reinstalling apps from the app stores (via share dialog). It worked so well when I was moving between OxygenOSes and then to custom ROMs (Android 11) I made plans to do a write-up, with screen recordings of it in action. Laziness and procrastination set in. :sleepy: May still do so.

It’s a problem with SeedVault too.

It’s less of a problem with Android Backup and Restore Tools project. That needs root or rooted debugging, but if you’re using App Manager then you already have root. Why not give it a try?

AM works perfectly without root (lacking some functionalities, of course). That’s my case as least.
So: AM != root :wink:

Sorry - my mistake. I missed the bit in @marcdw’s post about AM and non-root users

1 Like

Having time on my hands (currently unemployed) I deciced to do some ROM testing on my Oneplus 8T.
Was running Carbon ROM (my go-to). Finally decided to try the Linux Android Backup tool after I saw the app show up in F-Droid (IzzyOnDroid repo). Heretofore known as LAB.

On Linux I ran the backup script and followed all the prompts. It installs the aforementioned app to backup contacts and then proceeds to backup all apps (but apparently not their data if I read correctly at the github) and internal storage. That went without a hitch.

The next day I tested /e/OS on the OP8T for fun. Later I installed CorvusOS and decided to see what happens if I tried the LAB restore. Knowing that I’m on a different ROM it would be sure to break things but that was okay.
The restoration went well. It didn’t fail but there were some errors/warnings. For instance I had Termux installed on Corvus because I needed a terminal to deal with some microG permissions but forgot to uninstall it before the restore. CarbonROM had TEL (Termux Expert Launcher) which has the same package name as Termux. During the restore TEL didn’t get restored due to signature mismatch. Otherwise everything else was restored including all the internal storage stuff. There were some adb errors at the end but nothing that stopped the restore.

When I went back into the ROM all the apps I had installed on Carbon (other than the TEL stuff) was there. Surprisingly nothing was broken in the ROM so that was good. Probably because only user apps are backed up and restored.
For safety reasons I figured I’d reflash the ROM, wipe data, and reinstall the apps fresh. I did two /data wipes but nothing was removed. All apps and the ROM settings were still intact. Odd.
Using OrangeFox recovery by the way. On the second wipe I clearly saw that directories and other items were gone, yet I guess not.

As far as backing up contacts, not sure what happened with restore. When I brought up Contacts there was nothing there. Not a problem for me since I use EteSync anyway but not sure what happened. May have missed an error message regarding that.

In general though it seems that Linux Android Backup worked fairly well. I used Neo Backup to restore data. A mult-tier approach is always good. Just in case I did manually copy /sdcard/ contents to an external drive,.

Sidenote: I have never trusted USB-powered external drives. Random loss of power or going to sleep and not waking up, failures to write, etc. Awhile back I put a 500GB SSD drive in an AC-powered UGREEN 3.5" enclosure. Inexpensive but so far no issues and reliable.


That looks really interesting. No mention of root on their github. Can you confirm whether it works OK with an unroofed phone? Thanks

Does LAB not backup and restore data? Or is using it just a ‘belt and braces’, ‘just in case it doesn’t work’. multi-tier approach?

I was not prompted for root during backup or restore. It uses adb for access and commands.

Sadly, app data is not backed up, as confirmed here…
Issue # 24 (Question on apk files data backup)

External data will be present (/sdcard/Android/), so only half good. Folks will still have to reconfigure their apps.

sigh All folks want is to retain their settings without having to jump through hoops or root their phones.

Also, missed the chance to see if App Manager could restore data in adb mode. I accidently deleted its backup directory. Good thing I wasn’t relying on that. :open_mouth:

Yes. And I can do that using the Android Backup and Restore Tools on a linux computer. I was hoping that LAB might give us that functionality on MacOS (and on Windows if people insist on using it :wink: ). Looks like I’ll have to make start on trying to get AB&RT runnng on MacOS

Well, after awhile I discovered that LAB’s internal storage restore didn’t work out so well.
Found out that only a fraction of my images were restored. During restoration I did see some errors regarding .thumbnails or some such. Before noticing my issue I did read an issue on the github where it seems that when said errors occurred nothing else in the affected directories would get restored and it moved on.
So in my case only images in the top-level Pictures were restored. All subdirectories were omitted. That’s not good.

Later, when I was about to restore my SMS/MMS messages with SMS Backup & Restore, its directory wasn’t present. ???
Another directory for my office suite was only partially populated. With those discoveries and more I wound up having to do a manual compare and restore from the external drive to the phone.

I’m about to do another ROM change on that phone. Next time I’ll try AB&RT as it sounds more reliable.